0

I am facing a weird issue, not sure if anyone else has come across something like this before.

I have two Raspberry Pi 4Bs with Raspberry Pi OS installed.

I can't ssh into them using my laptop for some reason.

I have tested using multiple devices, some work, some don't.

  1. Windows 8 (Home PC, Acer) | Putty, GitBash | Connects without any issue.
  2. Windows 10 (Bro laptop, X1E2) | Putty, GitBash | Connected the first time, but could type any commands. Does not connect subsequently.
  3. KDE neon (my laptop, T480s) | Kterminal | Connected the first time, but could type any commands. Does not connect subsequently.
  4. Windows 10 (my laptop, T480s) | Putty, GitBash | Connected the first time, but could type any commands. Does not connect subsequently.
  5. Android app called RaspController | Connects without any issue.
  6. Windos 10 (Surface) | Putty | Connects without any issues.
  7. Wife's macbook | Terminal | Connects without any issues.

For those that do not connect, if I type the wrong password, it says permission denied immediately. But if I type it correctly it is just stuck there doesn't start shell session. Sometimes I manage to connect (usually after i delete .ssh), but when I do then I am unable to type anything. Deleting .ssh/known_hosts and even .ssh from the home directory does not work.

I have tried reinstalling raspbain/Raspberry Pi OS multiple times and also swapping around the sd cards (this was before I realized some devices could ssh in without issues). I have upgraded everything on my laptop as well.

Both the T480s and X1E2 are able to ssh into other devices without issues (laptops).

I have tried ssh-ing from both Pis into each other, no issues as well.

I have also reinstalled openssl-sever on the Pis.

Anyone has any suggestions as to what I can look into next? I previously suspected the two Thinkpad models T480s and X1E2 had some issue but since they can ssh into other devices I guess not?

  • Welcome, on the ones that cannot connect have you set any strange terminal emulation up or tried deleting the device definitions? Is every machine on the same version software (well PCs at least)? – Andyroo May 30 at 9:46
  • 2
    Given that at least one machine can connect and work properly suggests that the fault is in the other boxes. Nothing to do with the Pi. – joan May 30 at 9:58
  • "some work, some don't" is not helpful. This is unlikely to be a Pi problem, but if you want anyone, anywhere, to help you need to provide some evidence such as error messages. – Milliways May 30 at 11:04
  • Hi @Andyroo, thanks for your reply. All terminals are "stock". By deleting device definition if you mean the config saved in Putty then yes. Yes the Windows 10s are on the same version, one PC is on windows 8. – Ash May 30 at 11:23
  • Hi @joan, that is what I initially thought as well, but the fact remains that the two machines that cannot ssh into the Pis are able to ssh into other laptops without any issues. I am not ruling out the fault being in the machine, I am trying to investigate that angle as well, but I don't think there is sufficient evidence at the moment to decisively rule out the issue being on the Pi end. – Ash May 30 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.