1

I tried to install Ubuntu 18.04 on Pi4. I followed the link from ubuntu for pi. After inserting the SD card with Ubuntu image, the error appeared after few lines with

[FAILED] Failed to start Load Kernel Modules

I searched and got the same question in the link below, but still can not solve the issue. Link:askubuntu-FAILED to start load Kernel modules

Please help. Thanks!!!

6
  • 1
    so you went through the answers and tried them all? - oh, wait "I followed some of above advice" - what did you try? what didn't you try? why didn't you try it? Commented May 31, 2020 at 9:08
  • and what's the output of sudo systemctl status systemd-modules-load.service Commented May 31, 2020 at 9:10
  • I did apt-get update dpkg --configure -a apt-get dist-upgrade apt-get -f install, the error is still there. When I tried "sudo apt-get remove nvidia-* sudo apt-get autoremove sudo nvidia-uninstall" there was an error with nvidia-uninstall. Commented May 31, 2020 at 12:33
  • @JaromandaX output of "sudo systemctl status systemd-modules-load.service" is : Active: Failed (result: exit-code) Failed to find module 'parport', Failed to find module 'ib_iser' and Failed to start Load Kernel Modules. Commented May 31, 2020 at 12:36
  • Is your OS compatible with ARM? Commented May 31, 2020 at 20:14

1 Answer 1

0

dist-upgrade is the kiss of death on Ubuntu.

It tries to replace the Pi specific boot code and firmware with EFI code.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.