0

I am newbie to Raspberries, and I couldn't install the driver correctly. My Raspberry PI 0 is the version without wifi, and i am trying to install the driver offline of an wifi usb dongle (Realtek 8188eu).

No interfaces were detected after installing the driver from .deb file. Using the "dmesg" command, the only error message shown is: "device descriptor read/64, error -32". Using the "ifconfig -a" there is only the loopback interface.

Any help??

Thank you

1

I would use the software from fars-robotics created by MrEngman as the driver depends on the version of Raspberry Pi O/S you are running and it's a bit of a pain (though doable) to work out the version you need.

The process is plug the adapter in the USB port

Get the install program (make sure you copy the whole line):

sudo wget http://downloads.fars-robotics.net/wifi-drivers/install-wifi -O /usr/bin/install-wifi

Make it executable:

sudo chmod +x /usr/bin/install-wifi

Display the help text:

sudo install-wifi --help

I would run it with the check option first to see if it recognises your dongle. I've had a 'fake' before now that did not have a recognised chip in it despite the Amazon seller stating it did...

| improve this answer | |
  • Hi @Andyroo, I cannot connect to the internet, but i downloaded the "install-wifi" script from the link above and moved it via flash memory drive to the raspberry pi, but I got the following error: "Make sure you have ca-certificates installed and that the time is set correctly", any idea how fox that offline? – user3132623 Jun 6 at 15:07
  • The first thing the script does is they to update itself from the web - f it does not have access it will throw this as a general error. You could try hacking the script to remove the call to update_self that may well get you the version and file details you need to download the drivers from downloads.fars-robotics.net/wifi-drivers and then manually install them. Not something I have tried though! – Andyroo Jun 6 at 15:26
  • I will try it and get back if it works, thanks! – user3132623 Jun 6 at 17:19
0

can you connect with hard wired Ethernet? have you tried sudo apt install firmware-misc-nonfree without providing more info on which wifi device you have, it's difficult to help. what does lsusb output provide with respect to the wifi device you have?

| improve this answer | |
  • The Raspberry Pi Zero does not have wired port. He cannot use a wired connection without an additional USB/Ethernet dongle. Please don't ask questions in an answer. An answer should not need interaction of the questioner. – Ingo Jun 1 at 10:57
  • Hi @amf99, as mentioned the device is Realtek 8188eu, and the lsusb entry is: 0bda:f179 Realtek Semiconductor Corp." – user3132623 Jun 6 at 15:08
  • Hi user3132623, after reviewing the script that @Andyroo provided the link too, the script indicates driver 8188fu should be used. On a new install of 2020-02-13-raspbian-buster-full, there is a 8188eu driver located at '/lib/modules/4.19.97+/kernel/drivers/staging/rtl8188eu/r8188eu.ko'. I think the eu vs fu is just a versioning thing. Try loading that module with modprobe. You will have to configure wpa_supplicant.conf for your access point. If that driver works, then just add it to '/etc/modules'. Hope this helps. amf99 – amf99 Jun 7 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.