I have a Pi Zero W which I want to use for the MagicMirror.

Because of some hardware limits I have to install "Jessie" to make it work.

No problem there. The problem is that I need to add the WiFi and SSH details to the SD-card before booting. I'm running a headless system and can't be bothered with a keyboard/mouse.

So after some Googling I found that adding a text file wpa_supplicant.conf with the following contents to the SD-card root it will copy it to the location it needs to be and WiFi will work.

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 network={ ssid=“SSID HERE“ psk=“PASS HERE” key_mgmt=WPA-PSK }

The Pi Zero W running Jessie doesn't.... The Pi 4 running Raspberry Pi OS does....

So I thought maybe Jessie is to old and the functionality isn't added yet... Well no.
Jessie is from 2017 and the function is added in 2016..

So.. can anybody help me out here?

  • Not sure if it's a cut and paste issue but the ctrl_interface and GROUP should be on the same line. Did you use sudo to edit it or did you do it on a PC / MAC? You may have carriage returns in the file - only line feeds are allowed. Check quotes - Macs can autocorrect. Check if SSID or password have odd characters in them. Do not put the file in /boot create it as sudo nano /etc/wpa_supplicant/wpa_supplicant.conf
    – user115418
    Commented Jun 1, 2020 at 22:05
  • 2
    If you insist on using a 3 year old OS you should search 3 year old posts and IGNORE later posts.
    – Milliways
    Commented Jun 1, 2020 at 22:35
  • @Andyroo. I did check all of that. I can’t SSH into the pi because there is no internet connection. Funny thing tho’ the empty file names ssh does work. When booting the pi comes with the warning message about not save ssh. Commented Jun 2, 2020 at 3:48
  • 1
    @Miliways. True but how does this helps me? Commented Jun 2, 2020 at 3:48
  • 1
    @Andyroo dude..... "Check quotes - Macs can autocorrect." <---- THIS I copied it from a website. Then converted it to flat text. However quotes aren't converted. Changed them and now it runs.... I feel stupid. Thank you! Commented Jun 2, 2020 at 11:19

1 Answer 1


Going by the feedback from my comments I'll put this note here for others:

The standard editor on the Mac is designed to edit rtf format files by default but supports text mode via a menu option. This text format is suitable for Linux / Raspberry configuration files as it does not contain carriage return + line feed line endings only line feed.

The care you have to take is that even in this 'text mode' is the auto-correct spelling check is turned on and will alter the standard quotation mark (U+0022 or ASCII 0x22) to speech marks (U+201C and U+201D) unless you turn this off in the system menu / spelling options.

This character is traditionally shift-2 on a standard UK keyboard by the way.

The latest release of iOS (v13.5 as at the time this note was created - June 2020) has made this more complex with the English (UK) keyboard as the numeric shift function (.?123) shows an angled quote mark like two acute accents (U+00B4) but delivers a single quotation mark (U+0022). The same occurs for the apostrophe with the keyboard showing a single acute accent but delivering an apostrophe (U+0027). Long press will give you the correct character as needed.

The only other thing currently broken on the iOS keyboard is that cursor reposition by finger can turn on the shift key when you do not expect it...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.