2

I've installed the image Raspberry Pi OS (32-bit) with desktop and recommended software to microSD HC (Smartbuy 32gb) using Raspberry Pi Imager for Windows. Turning my R Pi on leads to loading screen stuck forever. Keyboard typing is enabled, but no command works. I double-checked memory card files and performed verification in Raspberry Pi Imager, everything seems to be OK.

I also tried to write OS img using balenaEtcher with the same result.

What do I need to check to solve the problem? Since I use Raspberry for the first time, the issue may be very simple.

UPD: I've tried other Raspberry Pi OS versions with the same result. Ubuntu 20 LTS for Pi 2/3/4 provides strange error output: Output

UPD 2, mod attention needed! Changing card to SanDisk Ultra 32gb resolved all the issues. So, basically, the answer is "It's SD card problem". But it's still unclear which standard exactly is violated by Smartbuy! Should I open a new question or continue the discussion here?

14
  • first boot usually takes a while as the root partition is being extended ... does the green LED flash while it "does nothing" Jun 4, 2020 at 2:26
  • The green light is on. I've tried to wait more than an hour - no result.
    – JustLogin
    Jun 4, 2020 at 2:27
  • I don't get what Keyboard typing is enabled, but no command works means ... the screenshot does not suggest this to be the case - oh, wait, there is a cursor, sorry - can you add to the question what raspberry pi model you have please Jun 4, 2020 at 3:02
  • Also, for a quick test, try the other two variants i.e. Raspberry Pi OS (32-bit) with desktop and Raspberry Pi OS (32-bit) Lite Jun 4, 2020 at 3:05
  • @JaromandaX completely same issue with Raspberry OS lite. Both leds are lit.
    – JustLogin
    Jun 4, 2020 at 3:26

1 Answer 1

2

The first thing I would do is getting an SD card from a reputable brand such as Samsung, Sony, SanDisk, Lexar, Transcend, Kingston, PNY, etc. and avoid buying it in a shop which also sells Smartbuy, Goodmem, Kingstick and other "brands" that are either completely unknown to Wikipedia, sound fake, or don't belong to companies producing computer hardware. For instance, Smartbuy is a house brand of Flipkart which is an Indian equivalent of e-bay: they don't produce any electronics, only resell.

Tools such as FakeFlashTest can detect some of the problems plaguing fake SD cards such as mismatch between real and reported capacity. However, some subtle electrical problems may not be detectable on a PC and still cause failures on a Pi.

3
  • If my card is failed how do I describe the problem to get a return? Because if it is there's some kind of issue I can refer to.
    – JustLogin
    Jun 4, 2020 at 12:53
  • 1
    Your guess is right. Everything works without a single issue on SanDisk Ultra 32gb. NOOBS runs fine too while on Smartbuy I got "Formatting error" even without starting. But there's still a question: which standard is violated?
    – JustLogin
    Jun 4, 2020 at 17:52
  • @JustLogin The exact problem is impossible to trace down without an extensive investigation. Some cheap cards don't support 1.8V which UHS cards are required to support. As a customer, I would simply request a refund for "defective goods", and stay away from no-name cards in the future. Jun 8, 2020 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.