1

I am using 7 inch HDMI touch screen with Raspberry Pi 4. I am having below issues:

  1. I have connected the HDMI cable to the touchscreen and connected the mini hdmi to hdmi0 of pi. I have also connected the power adapter to the touch screen slot of the screen. During bootup, I can see the OS loading but after that I do not see the desktop and it keeps showing red color saying Not Support.

enter image description here

At this point, if I unplug and replug the HDMI cable, it then starts showing the desktop. I have double checked the HDMI cable with another monitor and the cable is fine.

  1. During the usage, if I keep the Pi idle for around 5mins, screen starts showing blue color. If I move the mouse the blue color goes away and it starts showing the above red color screen. I believe this can be changed from settings but I am not able to find appropriate settings for this.

  2. Touch is not working on the screen. Do we need to enable touchscreen from settings in pi.?

Has anyone experienced this type of issues with 7 inch HDMI touchscreen and raspberry pi 4. Can anyone please give me some ideas on how to resolve this. Please help. Thanks

Here is the link to touchscreen: https://robokits.co.in/raspberry-pi/raspberry-pi-hdmi-7inch-lcd-capacitive-touchscreen-10point-touch

15
  • 1
    @tlfong01 Here is the link to the screen: robokits.co.in/raspberry-pi/….
    – S Andrew
    Jun 4 '20 at 4:58
  • 1
    @tlfong01 I think you are right. Previously I was using raspberry pi 3 with non touchable monitor and then used the same sd card in pi4 with this hdmi screen. I will try to install new raspbian on this. So after that will it resolve the issues.?
    – S Andrew
    Jun 4 '20 at 5:21
  • 1
    Ha, if you are using the old SD card for Rpi3 with a no touch monitor, then the new Rpi4B with buster will be confused. Yes, if you flash a new card and try again, it is pretty likely that Rpi4 and the Display would immediately recognize each other and talk like old friends or twin sisters. Good luck and cheers.
    – tlfong01
    Jun 4 '20 at 5:40
  • 1
    @tlfong01 Can you also explain the uses of the command you want me to put in config.txt. Also I am not plugging the power of HDMI screen to usb of pi so I dont think I need max_usb_current=1
    – S Andrew
    Jun 4 '20 at 13:59
  • 1
    Ah, you know better than me. I copied from WaveShare wiki. As I said earlier, your display is only similar to WaveShare. It might be an old model, an OEM or ODM version. Usually the vendor gives you a CD with a setup script to automatically do the editing of the /boot/config.txt for the user. I think you should now guess why last time Rpi OS complained "Not Support" because you might have said hdmi-cvt 1280 x 1014 which your display does not support. You also need to read the friendly long and tedious /boot/config.txt manual page for the details on setting HDMI etc. Good Luck. Cheers.
    – tlfong01
    Jun 4 '20 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.