0

I am trying to flash EMMC in a Raspberry Pi Compute Module 3+ using Ubuntu 16.04 by following this tutorial. I have done the following in my host system:

mkdir ~/RPI_CM3+
cd ~/RPI_CM3+
git clone --depth=1 https://github.com/raspberrypi/usbboot 
cd usbboot
sudo apt install libusb-1.0-0-dev
make

But make command is failed with the error message:

./bin2c msd/bootcode.bin msd/bootcode.h
/lib/ld-linux-armhf.so.3: No such file or directory
Makefile:5: recipe for target 'msd/bootcode.h' failed
make: *** [msd/bootcode.h] Error 255

It seems to be a basic issue, but I couldn't find out a solution. Using this post, I tried:

sudo apt-get install libc6-armhf-cross
sudo ln -s /usr/arm-linux-gnueabihf/lib/ld-linux-armhf.so.3 /usr/lib/ld-linux-armhf.so.3

But this has not solved the issue. I don't seem to have these issues when using Ubuntu 18.04. Has anyone else come across this issue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.