1

I’ve got a Raspberry Pi 4 running Raspberry Pi OS, an HDMI monitor, and a female-male HDMI panel mount cable connected to an HDMI-micro HDMI adapter. When I hook my monitor up to the extension cable, I get no video output (although the monitor briefly turns on).

The extension cable works fine connected to my laptop.

The Raspberry Pi works fine connected directly to the monitor using the HDMI-micro HDMI adapter.

My config.txt has had these lined edited:

hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=1
config_hdmi_boost=4

I’ve also tried just setting hdmi_safe=1.

EDIT: Following some of the advice in this forum thread, I've also tried the following config.txt options (to no avail):

hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=81

And to confirm, I'm using the HDMI0 port.

1

Try setting config_hdmi_boost to a higher value, e.g. 7, and then (if 7 doesn't help) to 11. Hopefully a stronger signal will make it though the extension cable.

If that doesn't help, you should obtain a better quality cable.

1
  • This was a good shout - I should have read the docs on the RPi's video config, but sadly when I did, I discovered this: "config_hdmi_boost ... This option is ignored on the Raspberry Pi 4." – lowercasename Jun 4 '20 at 14:33
1

Happy to say that the problem turned out not to be the panel mount adapter, but the micro-HDMI adapter I was using. If anyone stumbles on this issue, make sure you're using a good one!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.