0

I currently have a Adafruit PiTFT - 320x240 mirroring the raspberry pis HDMI output. I have developed a GUI which I would like to run on the raspberry pi, which is designed for 320x240. The problem is that since the screen mirrors the HDMI output, and the HDMI output is 1280x480, I get a screen like this on the pi

Actual Output

enter image description here

Expected Output

enter image description here

I simply want the pi to just use the raspberry pi screen, 320x240 instead of the 1280x480 HDMI output. Is their a setting which allows for this?

1

The PiTFT screen can run in three modes:

  1. With the HDMI turned off
  2. With the HDMI mirroring the screen
  3. With the HDMI as a separate display /dev/fb1

You currently have the mirroring setup so you need to create a bespoke screen configuration in config.txt to set the HDMI screen to 320x240 ASSUMING you physical display can handle this resolution - doubtful as it's not a 'classic' monitor standard.

To do this, you need to be familiar with the details on the Raspberry Pi site here in the section entitled Custom mode. Note the section above This one (Which values are valid for my monitor?) will help you find out if the HDMI screen will support this.

Make sure you have SSH enabled and working - it's possible to end up with NO display that you can type instructions on when playing with bespoke settings!

Assuming it does you can put the following lines in the relevant section of you config.txt file:

hdmi_cvt=800 480 60
hdmi_group=2
hdmi_mode=87

The 60 value on the first line is for a 60Hz monitor and may need to be changed to match your equipment.

If this does not work (blank screen on the monitor) look at adding an aspect ratio to the first line or trying the overscan options (disable or scale) in config.txt

TBH:

  1. I do not expect this to work at all due to the low resolution required.
  2. I would reinstall the software configured for two separate frame buffers giving you much more flexibility and control.
| improve this answer | |
  • Could you link a guide for "reinstall the software configured for two separate frame buffers giving you much more flexibility and control." I tried previously, but the instructions in the guide I found were unclear. – Lyra Orwell Jun 5 at 16:27
  • @LyraOrwell Burried in the install notes is a comment that you can change your mind by just re-running the script sudo ./adafruit-pitft.sh again. Never tried the dual frame buffer programming though... – Andyroo Jun 5 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.