1

In short, the Pi just stopped booting.
I looked at the boot screen, which displayes FAILED messages:

Failed to start Load Kernel Module

and keeps rebooting after

A start job is running for dev-mmcblk0p6

I can't even enter commands at this point.
I checked how the SD Card looks in an Linux File Reader in Linux.
Now, I've aquired enough skills to realize that this isn't how its supposed to be

List of partitions

The partitioning seems... off. By a lot.
Is there anything I can do to restore the Pi?

2
  • 1
    looks like a standard NOOBS layout ... I'm kidding, never seen a noobs disk in my life, but I know it loves partitioning the life out of a disk Jun 5, 2020 at 23:03
  • 1
    In your other system run sudo umount /dev/sdb6; sudo fsck -f -y /dev/sdb6; sudo eject /dev/sdb [note I'm assuming it appears as /dev/sdb when you insert the USB reader]. Then try again in your RPi. If it still doesn't work write RaspiOS32 to another SDCard then rescue data & programs from the original card.
    – Dougie
    Jun 6, 2020 at 9:48

1 Answer 1

2

The illegible image is probably a NOOBS installation.

The error indicates something on partition 6 is not running.

This is probably caused by some file which has become corrupt.

If you have a backup you could try restoring from this.

Otherwise you should do a fresh installation - it is also advisable to use a new SD Card; these do wear out, and you should be able to recover your files from the old SD Card.

It is preferable to install Raspberry Pi OS rather than NOOBS, and if you REALLY need multiple OS on the one card use PINN

1
  • After some further investigation, it seems like the the device dev-mmcblk0p6 was located on a corrupted block. Probably due to power outage. I tried a lot of stuff, but it seems like the data is gone and this is the reason the Pi doesn't boot anymore. Thanks for your advice!
    – itzFlubby
    Jun 7, 2020 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.