0

I am trying to install barrier on my raspberry pi so to enable sharing my mouse and keyboard over LAN.

However when I run the command:

$ sudo apt install barrier -y
Reading package lists... Done
Building dependency tree
Reading state information... Done

I checked the apt-cache to see if I could it barrier

$ apt-cache search barrier
at-spi - Assistive Technology Service Provider Interface
between - game about consciousness and isolation
execnet-doc - rapid multi-Python deployment (docs)
htcheck-php - Simple php interface to database generated by ht://Check
komi - Single player arcade game with Komi the Space Frog!
libatomic-ops-dev - A library for atomic operations (development files)
libconcurrent-java - utility classes for concurrent java programming
libcurator-recipes-java - Apache Curator Recipes
libpwiz-dev - library to perform proteomics data analyses (devel files)
libpwiz-doc - set of programs to perform proteomics data analyses (doc)
libpwiz-tools - ProteoWizard command line tools
libpwiz3 - library to perform proteomics data analyses (runtime)
libzthread-2.3-2 - Object-oriented synchronization library for C++
libzthread-dev - Object-oriented synchronization library for C++
msn-pecan - alternative MSN protocol plug-in for libpurple
msn-pecan-dbg - debugging symbols for msn-pecan
neverputt - 3D miniature golf game
neverputt-data - data files for Neverputt
php-hamcrest - This is the PHP port of Hamcrest Matchers
python-execnet - rapid multi-Python deployment (Python 2)
python3-execnet - rapid multi-Python deployment (Python 3)
scap-workbench - Scanning and tailoring tool for SCAP content
singularity-container - container platform focused on supporting "Mobility of Compute"

I even made sure my sources repo was fine

$ cat /etc/apt/sources.list
deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
#deb http://plug-mirror.rcac.purdue.edu/raspbian/ stretch main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi


$ cat /etc/apt/sources.list.d/raspi.list
deb http://archive.raspberrypi.org/debian/ stretch main ui
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ stretch main ui

Yes I did do an sudo apt update prior to the me attempting to install barrier

Does anyone have idea to fix this issue?

1
  • perhaps you need to be running buster rather than stretch – Jaromanda X Jun 6 '20 at 2:01
1

Install Raspberry Pi OS which has barrier in its repository.

You could try downloading from the barrier website.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.