I've downloaded the newest Raspbian release and it is a little bit different than the original one.

In particular, it gives a whole bunch of options to configure it the first time you boot it up. I'm just trying to do something simple like change the locale and I just don't understand what is happening. I hit enter on locale then it asks to choose a locale to be generated, so I scroll down to en-US.UTF8 UTF8 and hit enter again. Rhen it brings me to a screen that says lets you select default locale for the system enviorment: None or en_GB.UTF8 Which one should I select?

up vote 21 down vote accepted

Since you are in the United States I would enter none. You can change this after your Raspberry Pi has finished the setup process if needed.

In order to set the locale after you've setup Raspian run the following command to select the locale you want to generate.

$ sudo dpkg-reconfigure locales

It will then ask you which one should be the default. If you access your system via SSH it's advised to set it to none.

References

  1. Locale - Debian Wiki
  • Ooh! Thanks for that last line "If you access your system via SSH it's advised to set it to none". That'll come in handy down the line. – EGHDK Jul 18 '12 at 3:44
  • I just posted what I read, you may want to read the whole article to see if there are any other gotcha's. – user46 Jul 18 '12 at 3:50
  • 2
    Why does SSH affect locales? – Alex Chamberlain Jul 18 '12 at 6:26
  • 1
    @AlexChamberlain Though it is not likely to be an issue with the Pi in the vast majority of cases Locales controls how numbers and dates are formatted (i.e. mm/dd/yyyy vs dd/mm/yyyy). So if a computer is in America but accessed by a European user they can get dates and numbers formatted correctly for them. – Steve Robillard Jul 18 '12 at 7:43
  • The Debian Wiki reference is crucial here: it tells you how to configure your console (so direct access, not through a SSH connection) to default to a locale if nothing has been set (like through a SSH connection); the ${LANG:=<locale>.<codec>}; export LANG syntax in /etc/profile is important there. – Martijn Pieters Feb 5 '15 at 10:45

To mark a locale in the long list you have to press spacebar, after that you go out with enter and select your default locale with enter again.

  • Very helpful...I couldn't figure out how to actually make a selection! – brianz Jun 24 '14 at 20:51
  • I can't upvote enough. I also could not figure out how to make a selection. – Jason yesterday

For me in the US, I set my locale to EN_US UTF 8 and the WIFI 5GHZ worked for me.

On my Wireless Router, I had N-Only mode (5GHZ) as I used DDWRT for the firmware.

One note from @malleYay was to use to SPACEBAR to select the options first before pressing the ENTER key

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.