I have raspberry pi 4 and when I boot it with sd card(I have tried to install with dd, rpi-imager, etcher, I have tried ubuntu, kali, raspberry) and It's allways stuck on rainbow screen. When I take same sd card and put it in raspberry pi 3 it works. When it powers on red LED lights one and green blinks 3-4 times.

I have tried:

Raspberry pi 4 stuck on rainbow screen, green LED flashes 4 times

Won't boot after removing and inserting the SD Card?

Green LED blinks 4 times, did I brick my Pi?

PI 4 sometimes doesn't boot after rebooting from command line

This happens with both screen connected and not connected. It's not power problem.

  • it's same on all of them. Commented Jun 9, 2020 at 9:04
  • 2
    Why a 2nd post ? raspberrypi.stackexchange.com/questions/113276/…
    – CoderMike
    Commented Jun 9, 2020 at 9:12
  • It's on stuck on screen on all of them, in questions is said ubuntu kali raspbian Commented Jun 9, 2020 at 9:22
  • I think your raspberry pi 4 is dead then - based on your previous question that had some good detail in it Commented Jun 9, 2020 at 9:23
  • Hi @thisdoulsdowrk and welcome to the site. I've closed this question as a duplicate. Seems the original question was posted by another account of yours. Please do not create multiple accounts. I would recommend taking the Tour.
    – Darth Vader
    Commented Jun 10, 2020 at 16:10

1 Answer 1


Sorry to hear about your problem. Now at this point I must ask the capacity of the SD card you're using and also the speed of it. It is really important that you use a class 10 SD card for a cheap alternative of class 4 would take ages to boot. And talking about the capacity, the official website says that you can use any capacity more than 8 GB but it's important to know that you need to format the card in a FAT32 format. FAT32 file format is default when you're using capacity between 8-32 GB. but in case of higher capacity Disk (like 64 GB or 128 GB) the default file system gets changed to either NTFS or exFAT. NTFS is a microsoft patented technology, unavailable file format on your Raspberry pi4 B, exFAT is also not supported till today. If it happens that you have a higher capacity disk (sd card). Please use a third party formatting tool called SD CARD Formatter. There you will get a prompt to select the type of File System you need to format to. Select the FAT32 format but I must tell that you won't be able to utilize full 100% of the capacity. That's all mate! Have a great day.

  • 3
    If you are flashing an image you do not need to format the sd card. Read OPs other post for sd card sizes.
    – CoderMike
    Commented Jun 9, 2020 at 11:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.