0

I would like to connect my RPi3 with wifi attached. I can scan all APs in my office using command "iwlist wlan0 scan". But I can't find IP address at response of ifconfig wlan0. I can connect to an AP using name/password at Windows. How can I connect to that AP and get IP address using DHCP. I set my /etc/network/interfaces:

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
sudo wpa_supplicant /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

content of /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant/wpa_supplicant.conf
update_config=1

network={
ssid="MiTAC-Wifi1"
key_mgmt=IEEE8021X
eap=PEAP
phase2="auth=MSCHAPV2"
identity="stan.huang"
password="rasp7890"
}

I doesn't work. How should I do with it?

  • Add country=TW as the third line in your supplicant config. – Dougie Jun 9 at 11:34
  • What operating system do you use? Raspberry Pi OS Buster? – Ingo Jun 18 at 9:30
  • GNU/Linux with kernel (4.19.57-V7+) – Stan Huang at Taiwan Jun 18 at 10:16
  • GNU/Linux are all Linux operating systems: Debian, Fedora, Suse, Slackware etc. They all behave different. Again: are you using GNU/Linux Raspberry Pi OS Buster? – Ingo Jun 18 at 10:46
  • My OS should be Raspberry Pi OS – Stan Huang at Taiwan Jun 19 at 4:03
1

You are using old deprecated settings for WiFi. I don't know where do you get this. With Raspberry Pi OS, WiFi is working out of the box. You only have to use the right settings. I suggest you start over again with a fresh flashed Raspberry Pi OS image of your choice. Then follow the official documentation for Wireless connectivity in the Raspberry Pi Desktop or Setting up a wireless LAN via the command line.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.