0

Following this question I have modified /etc/xdg/lxsession/LXDE-pi/autostart to read:

@xset s off
@xset -dpms
@xset s noblank
@midori -e Fullscreen -a http://localhost:8080

However, when it boots up it does not go fullscreen, it is windowed. My guess is that the script runs before all of the graphics drivers are loaded so the screen size is yet to be determined so maybe adding in a delay somehow would work? This is a raspberry pi 0.

1

I would create a little script along the lines of:

#!/bin/bash
sleep 5s
midori -e Fullscreen -a http://localhost:8080

Make it executable with

chmod +x yourscript.sh

and call that in autostart.

Five seconds can seem like an eternity but gives the Zero plenty of time to get itself up and running.

2
  • Unfortunately that didn't solve the problem, running midori just from a shell I discovered that the flags are either not working or causing errors. I was able to get it to go fullscreen by removing the -a flag but then the address bar is focused and would need to be unfocused to hide. These errors make me think that the version installed is buggy (7.0) or doesn't work with the rpi0. Ultimately I decided to use another browser. Jun 9 '20 at 15:43
  • I'll mark as answered though because you did answer my poorly worded question :D Jun 9 '20 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.