0

I've just setup a Raspberry Pi 3B+ with the latest Raspberry Pi OS image (all tools). I'm trying to install Jupyter on it using the command 'sudo pip3 install jupyter' and I get the following errors;

Error: notebook 6.0.3 has requirement jupyter-core>=4.6.1, but you'll have jupyter-core 4.4.0 which is incompatiable.

Error: jupyter-client 6.1.3 has requirement jupyter-core>=4.6.0, but you'll have jupyter-core 4.4.0 which is incompatiable.

My version of pip3 is 20.1.1. The Raspberry Pi OS is; Raspberry Pi OS (32-bit) with desktop and recommended software Image with desktop and recommended software based on Debian Buster Version:May 2020 Release date:2020-05-27 Kernel version:4.19

Please could someone let me know how I can fix these?

Kind regards.

Alex.

2 Answers 2

0

Try using --upgrade which should upgrade the dependencies too:

sudo pip3 install jupyter --upgrade

If that doesn't work, I'd try upgrading jupyter-core first:

sudo pip3 install jupyter-core --upgrade
0

Pip is not always the best choice on RPi. I've had a few failures esp. where dependencies are concerned. I suggest you uninstall you're current Jupyter installation, and install Jupyter from the the Raspberry Menu -> Preference -> Add/Remove Software, Jupyter can be found as version jupyter-4.4.0-2.

I'm fairly sure that will do the trick since I have Jupyter running on one of my Pi3s quite nicely

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.