0

My audio on the Raspberry Pi 1 (Yes, I have an original model) on my Raspbian 10 Lite installation works, but only barely. Allow me to explain. I picked Raspbian 10 because I wanted to set up my own window manager environment instead of using an off the shelf desktop environment on my Raspberry pi, because I wanted better performance. I have the window manager working just fine, but my audio support is all over the place.

  • Audio seems to work OK with speaker-test...
  • But if I try to compile a Quake source port called Qurp, it complains it can't find bcm.h or something. I know that header is related to the audio because I've seen "bcm" appear in all sorts of Alsa configuration stuff.
  • If I try to listen to music with cmus, it takes forever to launch despite being a tiny terminal program, and when I finally get in, find a song, and hit enter to play it, the entire program freezes and no audio is played.
  • I have Doom set up on my Pi via chocolate-doom. It works OK unless I have audio enabled. If audio is enabled, it keeps complaining in the console about some pcm underflow or something, and the game runs extremely choppy even at the lowest resolution available, and the audio is extremely choppy and unbearable too. But, if I turn off all the audio through chocolate-setup, the game runs fine.

All I did to set up Alsa was to install some Alsa packages as I saw fit. I suppose I clearly didn't do enough to set it up properly, because it runs about as well as a morbidly obese lobster with no legs, and I can't seem to get anything that makes use of audio for more than a second to work right. How do I set up and configure audio support on my Raspberry Pi 1 manually, so that it works consistently and doesn't crash entire programs?

I'm away from my Pi right now, but I'll be back later today.

  • Have you tried running on a later version of hardware? Does that make any difference? – Seamus Jun 10 at 20:05
  • I've had good experiences with newer raspberry pis in the past, it's just this very first one that I'm having issues with. – blehmeh98 Jun 15 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.