1

I've been successfully using a 433mhz transmitter with my RPi 3 to control some remote sockets with 433mhz receivers. I recently moved the project over to my RPi Zero and the transmitter has suddenly stopped working. I've confirmed multiple times that everything is the same (code, wiring, etc.), the only difference is the micro-controller.

I've tried switching GPIO pins but am getting the same result. I do know that the GPIO pins are working as I am able to read data off of a DHT22 with no problem. I was thinking that it is a power problem but I am using the same power supply between Pis. I have also confirmed that the transmitter has not been fried as it continues to work when using the RPi 3.

I'm really struggling to figure this out and would appreciate any insight. Thank you!

1

Three possible reasons: 1. Because it has slow processing rates , thus it has lower sampling rate. 2. Because of the hardware configuration. 3. The hardware can not generate the processed signal.

3
  • Thank you. So one possible solution would be to overclock the Zero then? I don't believe the hardware configuration (wiring) is the issue as it is exactly the same as when I try it on the RPi 3. The fact that the RPi 3 can be used to successfully transmit a signal makes me think it's not a hardware issue. – Jake Friedman Jun 12 '20 at 20:29
  • @JakeFriedman No no no. I am not talking about the wiring. Wiring is not an issue here. – Sohan Arafat Jun 12 '20 at 20:46
  • Are you referring to hardware capacity then? What do you think the next steps should be? – Jake Friedman Jun 15 '20 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.