Memory Error while installing tensorflow in raspberrypi-buster enter image description here

  • 3
    DO NOT post pictures of text - post text!
    – Milliways
    Commented Jun 21, 2020 at 23:06
  • I vaguely remember I had some sort of memory error when installing TF. Then I was advised to expand swap memory and problem solved.
    – tlfong01
    Commented Jun 23, 2020 at 1:12

1 Answer 1


TensorFlow will install on a RPi but it has been a bit of a nightmare. The instructions of the TensorFlow site are here, but I had to hunt around for version that would install since the standard one would not.

That said I've just tried an install on a new 8G Rpi4 using pip3 install tensorflow and it installed straight off, so I presume TensorFlow have fixed the previous Rpi install problems. Just make sure you use pip3 and not pip.I haven't run tensorflow on the 8Gb Pi but it has run ok on a Rpi 3 previously.

The installed version was given as

Successfully installed protobuf-3.0.0 tensorflow-0.11.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.