0

While trying to host a website to control GPIO over flask and Apache I am now receiving the error that 'Failed to start The Apache HTTP Server'. Some googling suggested that this might happen if other servers are listening on port 80 so I did sudo ss -ntlp 'sport = 80' and returned two, both of which were lighttpd.

sudo service apache2 restart is what I executed when I first received this error; I was able to get the 'It Works!' page when I first instlled Apache.

How can I disable/turn off these servers using port 80?

2

You can stop lighttpd if you run

sudo systemctl stop lighttpd

If you are sure to disable lighttpd (don't want to run it again).

sudo systemctl disable lighttpd
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.