0

I am looking forward to install CouchDB on my rpi 3, running Ubuntu 20.04.

However, I can not figure out how to install one of its required dependencies: libmozjs185.

I have tried:

$ sudo apt-get install -y libmozjs185-1.0 libmozjs185-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libmozjs185-1.0
E: Couldn't find any package by glob 'libmozjs185-1.0'
E: Couldn't find any package by regex 'libmozjs185-1.0'
E: Unable to locate package libmozjs185-dev

Perhaps I should compile libmozjs185, but I would prefer installing a build. If that is not possible I want to follow the right steps to compile and install it.

How can I install libmozjs185 on my pi3 running Ubuntu 20.04?

0

I have had to search the armhf (I used pkgs.org for this) builds of these dependencies, but note that libmozjs185-dev depends on libmozjs185-1.0 which depends on libffi6.

# Download libffi6
wget http://ftp.br.debian.org/debian/pool/main/libf/libffi/libffi6_3.2.1-6_armhf.deb

# Download the libmozjs185-1.0
wget http://ftp.ro.debian.org/debian/pool/main/m/mozjs/libmozjs185-1.0_1.8.5-1.0.0+dfsg-6_armhf.deb

# Download the libmozjs185-dev
wget http://ftp.br.debian.org/debian/pool/main/m/mozjs/libmozjs185-dev_1.8.5-1.0.0+dfsg-6_armhf.deb


# Install libffi6
sudo dpkg -i libffi6_3.2.1-6_armhf.deb 

# Install libmozjs185-1.0
sudo dpkg -i libmozjs185-1.0_1.8.5-1.0.0+dfsg-6_armhf.deb 

# Install libmozjs185-dev
sudo dpkg -i libmozjs185-dev_1.8.5-1.0.0+dfsg-6_armhf.deb 

# Fix eventual missing dependencies
sudo apt --fix-broken install
| improve this answer | |
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Jun 26 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.