0

I've been trying to follow this guide: https://pimylifeup.com/raspberry-pi-wifi-extender/ to implement a wifi extender. For a USB wifi dongle, I just happened to have "OURLINK AC600" which contains the rtl8812au. I have installed this driver: https://github.com/abperiasamy/rtl8812AU_8821AU_linux and now wlan1 comes up.

For my hostapd.conf settings, I used the settings from this site: https://github.com/igorpecovnik/hostapd/issues/1

interface=wlan1
ssid=WiFi_SSID
channel=5
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=Some_PassWord
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
driver=nl80211
ieee80211ac=1
hw_mode=g

The hostapd service is failing to initialize. When I run 'journalctl -xe' I get the following:

-- The unit hostapd.service has entered the 'failed' state with result 'exit-code'.
Jun 17 13:21:09 raspberrypi systemd[1]: Failed to start Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator.
-- Subject: A start job for unit hostapd.service has failed

and when I run 'sudo cat /var/log/syslog | grep -a 'hostapd'' I get the following:

Jun 17 13:21:41 raspberrypi systemd[1]: hostapd.service: Service RestartSec=2s expired, scheduling restart.
Jun 17 13:21:41 raspberrypi systemd[1]: hostapd.service: Scheduled restart job, restart counter is at 44.
Jun 17 13:21:41 raspberrypi hostapd[2834]: Configuration file: /etc/hostapd/hostapd.conf
Jun 17 13:21:41 raspberrypi hostapd[2834]: Configuration file: /etc/hostapd/hostapd.conf
Jun 17 13:21:41 raspberrypi hostapd[2834]: nl80211: Could not configure driver mode
Jun 17 13:21:41 raspberrypi hostapd[2834]: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Jun 17 13:21:41 raspberrypi hostapd[2834]: nl80211 driver initialization failed.

Another post (https://www.raspberrypi.org/forums/viewtopic.php?t=235145) instructed to try and install an earlier version of hostapd, but the command shown to install the specific version no longer works:

apt-get install hostapd=2:2.4-1+deb9u2 -V
E: Version '2:2.4-1+deb9u2' for 'hostapd' was not found

How can I get this setup to work?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.