0

My pi 3b+ works with an SSD disk connected through USB and it was working with nextcloud for more than 1 year.

Pi stopped working, I could not access online, the apache server was not responding and didn't show an image at startup.

I have changed the power supply, also the dvi cable but it still did not work... I checked the config.txt file and for some reason it was empty, then I used the content of another config.txt I had on a minisd card I copied the config.txt content from that card.

Then raspi starts but was left with a blinking cursor on the berries screen. The last thing that occurred to me was downloading the latest raspbian distribution and copying almost all the contents of the / bot partition to my old partition.

The result has not been good ...

[0.060090] raspberrypi-firmware: 0.00000002 returned status 0x80000001 [0.070108] raspberrypi-firmware: request 0x0000003 returned status 0x80000001

Hardware seems to be ok I could start the same pi with a minisd and I can read the SSD.

The last thing I want is to have to delete everything and reinstall since I had a small web page and above all I would like to be able to recover all the content of nextcloud pics and all that.

1
  • Write a copy of RaspiOS to a new SDCard. Insert that in the slot on your RPi3B+. Open an lxterminal and use sudo apt install gparted then run it with sudo gparted. You should be able to repair the filesystem on your hard drive using that.
    – Dougie
    Jun 24, 2020 at 18:07

1 Answer 1

2

It seems your SD Card has reached end of live. If so it will not help much do any (new) installations on it again. You should use a new SD Card and do as less as possible working with the old SD Card, in particular writing to it. So it may be possible that you can still read the data from it and copy it to the new SD Card as long as it will not fail completely.

3
  • I'm not sure about it but just in casse I ordered a new SSD...anyway I started the pi with an MicroSD Card then I updated and upgraded the system so after it I connected the SSD and the MicroSD and first deleted the whole data stored in the SSD /boot and /boot/overlays then I copied the whole content from the MicroSD to the SSD Disk....What a surprise it started with the same simptoms as at the beginning it doesn't show the berries and doesn't send any signal to the screen. Jun 24, 2020 at 19:51
  • @CarlosMartínez Maybe I misunderstood you. Do you boot from the SSD?
    – Ingo
    Jun 25, 2020 at 15:59
  • "My pi 3b+ works with an SSD disk connected through USB"...yes I do. Jun 25, 2020 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.