1

I recently bought a (new) Model B Rpi 2011/2012 512MB to replace another identical model. I also added the same Wolfson audio card that the old Rpi had, and put the two connected items into a case.

I then took the SD card from the old rpi, expecting it to start up in the same way as the original as they seem to be identical.
I am using terminal rather than a monitor and keyboard.

The new pi does not appear on the network and I am wondering if I am missing out a step in setting up the new kit.

Would welcome any advice, thanks

  • Without knowing what OS, how you configured networking any why you needed to "replace another identical model" this is unanswerable - although you will probably get lots of idle speculation – Milliways Jun 26 at 9:43
  • Thanks. I suppose the underlying question is if two sets of hardware are seemingly identical in all respects, is it possible to simply swap an SD card between the sets? Or is further specific configuration required of the new set of hardware? – northdown Jun 26 at 9:47
  • you can, with some caveats, use the same sd card in 0, 0W, A, B, 2 (both revisions), 3, 3A+, 3B+ and 4 .... of course, only buster images work in 4, not sure about limitation for the others - so, moving an SD card from a B to a B is trivial – Jaromanda X Jun 26 at 10:18
  • "I am using terminal" - what sort of terminal? or is terminal a program on some other computer? – Jaromanda X Jun 26 at 10:22
  • Yes, with the original hardware I was logging in remotely using an SSH connection via the Terminal application of a Mac, and hoping to do the same with the new hardware – northdown Jun 26 at 11:07
7

How do you check whether it "appears on the network"? It is very likely that the new Pi gets another IP from your router than the old one did, because that is usually determined by the MAC address of the device. The easiest way to find the new PIs IP is usually to check in the configuration pages of your router. There's usually a page (maybe only in expert mode) that shows all the devices connected to it and their IPs.

| improve this answer | |
  • 1
    Thanks. I have been accessing the 'My Network' part of the router webpages and the device doesn't appear there. – northdown Jun 26 at 9:44
  • Check if it has an IP-number assigned using ifconfig. – Thorbjørn Ravn Andersen Jun 26 at 19:01
  • Thanks. I tried to set up last night with an 2015-05-05 raspian wheezy though mouse and keyboard do not seem to be recognised ( I am using raspberry pi branded power 5.1v, and the USB devices work fine on other machines) - it seems i have no way of interacting with the Pi, and wondering if it is defective? Using the 2015 wheezy image on booting I arrive at the raspi-config screen, but unable to procress with non functioning USB devices – northdown Jun 27 at 9:52
  • Mouse and Keyboard not working is pretty strange, indeed. But why did you try with such an old image? The raspberry firmware is constantly improved, so this may also explain USB issues. To make sure the Pi is not deffective, try with a recent Noobs image, then you can be sure it is technically working (or not). – PMF Jun 28 at 5:41
  • Thanks. I wanted to use an old Wolfson audio card with it the pi model B so used an older version that I had successfully used in the past. I also tried the current version of Debian 32-bit with similar results on the USB and networking. I'll give Noobs a try in any case, but coming round more to the idea the Pi is defective – northdown Jun 28 at 10:06
3

Although the hardware might be techically the same, at least the MAC Address of the Ethernet device is different. If you have some configuration tied to the MAC Address, that configuration must be updated to the new MAC Address of the Ethernet port.

| improve this answer | |
  • 1
    Many thanks. Do you know if it is possible to edit the SD card? – northdown Jun 26 at 9:39
  • 1
    why would you edit the SD card? the configuration in this answer refers to router (DHCP server) configuration of "reserved IP based on MAC address" ... – Jaromanda X Jun 26 at 10:21
  • Thanks. The new Pi now appears on the on the network (via ethernet) with a DHCP assigned IP address, though any communication with the new Pi via SSH seems to time out. The old Pi had a static IP (according to the router this was assigned by the Pi). I am wondering whether I need to amend the configuration to somehow remove the fixed IP address. – northdown Jun 26 at 11:34
  • If the old PI had a fixed IP configured (not set by the router), then this should normally be taken over to the new PI as well, since you swapped the SD card. Looks more like your Pi is not booting. Can you see the green light flashing while it boots? I suggest you attach a screen to it to see what's going on. – PMF Jun 26 at 12:36
  • Thanks. On the old set up - there are 2 sets of LED: adjacent to USB are row of 5 LEDS that light up as follows: yellow, flashing green, green, red, green; & adjacent to power 2 LEDS: green and red, now green only. – northdown Jun 26 at 14:06
2

thanks all for help with this - i shall pursue this, found on eLinux.org

In some distributions, /etc/udev/rules.d/70-persistent-net.rules remembers which MAC address is associated with eth0, so each new device will be assigned as a different interface (eth1, eth2, etc.) due to the different MAC addresses. Editing /etc/udev/rules.d/70-persistent-net.rules to remove the invalid rules and rebooting may help fix the problem.

| improve this answer | |
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Jun 29 at 9:51
-1

If you are connecting via Wi-Fi, you need to connect your new Pi to the Wi-Fi network and enter the password. I discovered this recently (on a Pi Zero W), thinking that I could just swap the SD card and all the settings would transfer.

I only found that it wasn't connecting when I connected a monitor to the Pi.

| improve this answer | |
  • 1
    the model B does not have onboard wifi, and since wifi wasn't mentioned in the question, it's safe to assume wifi isn't at play – Jaromanda X Jun 26 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.