0

This is the error I get:

dpkg: error: parsing file '/var/lib/dpkg/status' near line 1740 package 'firmware-brcm80211':
 duplicate value for 'Status' field
E: Sub-process /usr/bin/dpkg returned an error code (2)

I don't really know what I am doing so any advice helps!

Edit: When I run sudo apt dist-upgrade -y I get

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  rpi-eeprom-images
Use 'sudo apt autoremove' to remove it.
The following NEW packages will be installed:
  libfl2 pciutils rpi.gpio-common
The following packages will be upgraded:
  apt apt-transport-https apt-utils base-files bind9-host binutils binutils-arm-linux-gnueabihf
  binutils-common bluez bluez-firmware ca-certificates curl distro-info-data dnsutils
  dphys-swapfile e2fsprogs firmware-atheros firmware-brcm80211 firmware-misc-nonfree
  firmware-realtek git git-man idn2 iputils-ping libapt-inst2.0 libapt-pkg5.0 libbind9-161
  libbinutils libcom-err2 libcurl3-gnutls libcurl4 libdns-export1104 libdns1104 libext2fs2
  libgnutls30 libicu63 libidn2-0 libirs161 libisc-export1100 libisc1100 libisccc161 libisccfg163
  libldap-2.4-2 libldap-common liblwres161 libpam-chksshpwd libpam-modules libpam-modules-bin
  libpam-runtime libpam-systemd libpam0g libpython3.7 libpython3.7-minimal libpython3.7-stdlib
  libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0 libss2 libssl1.1
  libsystemd0 libudev1 openssh-client openssh-server openssh-sftp-server openssl php7.3-cgi
  php7.3-cli php7.3-common php7.3-json php7.3-opcache php7.3-readline php7.3-sqlite3
  pi-bluetooth python-apt-common python-rpi.gpio python3-apt python3.7 python3.7-minimal
  raspberrypi-bootloader raspberrypi-kernel raspberrypi-sys-mods raspi-config rpi-eeprom
  rpi-eeprom-images rpi-update ssh sudo systemd systemd-sysv tzdata udev wpasupplicant
93 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/172 MB of archives.
After this operation, 8,833 kB of additional disk space will be used.
apt-listchanges: Reading changelogs...
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: error: parsing file '/var/lib/dpkg/status' near line 1740 package 'firmware-brcm80211':
 duplicate value for 'Status' field
E: Sub-process /usr/bin/dpkg returned an error code (2)
  • Did run run the update as Pi? Did you put sudo at the front of the command? What version are you currently on? – Andyroo Jun 28 at 4:24
  • Run sudo apt update;sudo apt dist-upgrade -y and add the full output to your question if it fails. – Dougie Jun 28 at 9:06
1

Seems there is something broken with your package lists. You can try to reinitialize it. You can direct delete the files containing the package lists and then update and full-upgrade it again. But I think it is better to do it under control of the package manager. How to do look at Raspberry Pi sudo apt-get update not working.

| improve this answer | |
  • I followed the steps in that link and I am still getting the same error as in the original post. – schnat Jun 29 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.