I'm trying to setup a raspberry 3 B+ headless by writing a wpa_supplicant.conf and adding to the boot directory of pi.

However, my pi keeps not connecting to my internet, and I believe its because my wifi's name is "Bob's wifi" (Bob's not the real name) and the apostrophe in it keeps getting messed up.

I've done lot of google searches and tried \u2019, \xe2\x80\x99. I've also tried escaping the apostrophe by ', ' "'"', but they all didn't work.

Then, I went to powershell on my laptop and used "netsh wlan show interfaces" to see how the SSID was printed there, and it showed "Bobâ?Ts wifi", while profile printed it just fine as "Bob's wifi".

I understand that this happens because powershell is reading the bytes not using UTF-8 but through some other encoding system, but I'm still lost and don't know what to do.

I know I can change the wifi name, but I really want to figure out the solution to this problem since I tried so much anyway. I would appreciate any help.

I've been using this string as wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
  • Have you tried ssid="Bob\'s wifi" – user115418 Jun 28 '20 at 21:37
  • I think you're looking in the wrong place for your error. ?, ", $, [, \, ], and + are the disallowed characters. Space and full stop are valid. Nothing says apostrophe's are disallowed. – Dougie Jun 28 '20 at 22:36
  • Thank you, I've tried both just now, but they didn't work however. – Inquisitor Jun 28 '20 at 22:49
  • Perhaps is this method of remote control no longer supported? – Inquisitor Jun 28 '20 at 22:50
  • The fact that powershell shows the ssid as Bobâ?Ts wifi means that it is NOT Bob's wifi - i.e. it is NOT an apostrophe – Jaromanda X Jun 28 '20 at 22:52

I assume that you are trying to connect to an iPhone (which you should mention).

If so the character is NOT an apostrophe - it is another Unicode character. If you search my answers in this Forum you will find a suggestion, but it is far easier to change the iPhone to a sensible SSID.

  • Thank you for your answer! The wifi was a google wifi, but as the name was typed with an iPhone that makes sense. I've tried looking through your answers, but there were too many to go through. – Inquisitor Jun 28 '20 at 23:15
  • I will definitely switch my SSID name, but I'm really curious if there is a way to use â?T to find the right unicode for the iPhone symbol? One thing I've tried is finding the hex numbers for â?T according to Windows 1252 page, which gave me e2 3f 54, but this did not match with Unicode or UTF-8. I would really appreciate your help. – Inquisitor Jun 28 '20 at 23:17
  • I found the post I think you were referring to: raspberrypi.stackexchange.com/questions/41069/…. I did find this before and tried the methods you suggested, but both of them didn't work for me. Is there another solution or way? – Inquisitor Jun 28 '20 at 23:24
  • You may find this an interesting background read dhenrie0208.wordpress.com/projects/bad-iphone-ssids-explained it will not fix it as it assumes Windows! – user115418 Jun 29 '20 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.