I have RPI4 model B and I've installed Kali Linux Kali Linux RaspberryPi 2, 3 and 4 on my SDcard 64gb through Balena Etcher but when powered on, my LG tv shows "no signal", HDMI is well connected.

I tried in config.txt:

  • hdmi_force_hotplug=1 -> "no signal screen"
  • hdmi_safe=1 -> "rainbow color splash screen"

Could you please help me ?


  • 1
    does the pi work with raspberry pi OS? – Jaromanda X Jun 29 at 10:34
  • yes it has been working with Raspbian for months. – WBRPI4 Jun 29 at 12:09
  • check HDMI cable
  • set hdmi_safe=1
  • try set parameters hdmi_group and hdmi_mode for your display (watch next point)
  • read this link
| improve this answer | |
  • Thank for help, it did not work, I tried that already. :( But I formated the SDcard again, and connected it to my laptop with USB-SDcard adaptor this time (was SDcard adaptor before). Tried only hdmi_safe=1 option, and 1sec after rainbow it has booted. But at the end I have black screen blinking with the mouse. There is nothing I can do. This is a nightmare :) – WBRPI4 Jun 29 at 15:40
  • hdmi_safe includes hdmi_force_hotplug (ie., enabling them both is harmless but redundant): raspberrypi.org/documentation/configuration/config-txt/video.md – goldilocks Jun 29 at 17:58
  • @WBRPI4 then the problem is most likely in drivers or the graphics environment cannot boot for any other reasons – Vladislav Tikhomirov Jun 30 at 10:28
  • @goldilocks indeed, did not notice when reading the documentation – Vladislav Tikhomirov Jun 30 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.