1

My monitor, an old Toshiba 47wlg66, will display what my boards output (whether it's my old Raspberry Pi 1 A or new Raspberry Pi 4 B) only if it was powered first. Otherwise it will remain black..

It is troublesome because I power the 2 at the same time, and the Pi's must be quicker to send their first signal because in that case the screen remains black and I need to power off and on the Pi for the monitor to recognize the signal.

I usually use dietpi, but have seen this behaviour with Raspbian as well. Is there a way to fix that, or at least some kind of signal I could send from a script that would tell the monitor to start listening as it does whilst booting?

2
  • Leave it all powered on!
    – Dougie
    Jun 29, 2020 at 22:19
  • @Dougie that won't do. People can mess with it, and I want a real fix..
    – Shautieh
    Jul 4, 2020 at 23:04

2 Answers 2

2

Bullseye update There is now an option in raspi-config Display Options to set VNC Resolution for headless operation.

The method below prevents other config.txt options from working.


You need to force HDMI output in /boot/config.txt (earlier models defaulted to composite, the Pi4 does nothing).

    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1

This requires a default resolution to be set in raspi-config (at least on the Pi4 - earlier models defaulted to VGA resolution).

It is also possible to set resolution manually, but in raspi-config it is easier to select a resolution supported by your monitor.

Mine is (this selects a different resolution if the wide screen Acer is detected) -

#DVI DMT (35) RGB full 5:4, 1280x1024 @ 60.00Hz
hdmi_group=2
hdmi_mode=35
[EDID=ACR-Acer_KA210HQ]
#DVI DMT (82) RGB full 16:9, 1920x1080 @ 60.00Hz
hdmi_group=2
hdmi_mode=82
[all]

NOTE don't just blindly copy the values above - set defaults which are supported by your monitor, so it will work if the monitor is connected.

1
  • When trying to get the right resolution with the pi4, I tried setting those hdmi groups with no great success. Specifying the framebuffer_[width|height] options did do the trick along with overscan_*. I'll try again setting the hdmi_group and the force hotplug next time I am in front of the beast!
    – Shautieh
    Jul 4, 2020 at 23:12
1

Is it because the Pi is defaulting to a low resolution? You can try setting the default resolution (within the configuration) to match the resolution of your monitor. I forget what the default resolution is but it is much less than monitors typically are - it's probably set to target the small touchscreens.

1
  • I don't think it's related, but I set a resolution already in my config.txt.
    – Shautieh
    Jul 4, 2020 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.