-1

I've been trying for years to get some kind of wwan card working on a raspberry pi. I've tried the AT&T LTE dev kit (got it working but not where I need to use it - protocol not supported). I tried a sierra wireless hotspot - couldn't figure out the tethering. I tried a Sim7000a - couldn't get it to work.

My latest attempt is that I picked up a Netgear 340u Beam, a USB connected cellular modem. I verified it works in windows. I have made sure it's not running the windows 8 specific firmware. The first time I plugged it into Ubuntu on my laptop, it fired up a net connection without my doing a thing. To make doubly sure, I used the instructions of setting up a connection on nmcli where you specifically give it the APN and name a connection, and it works just great in ubuntu.

The last time I tried it on the pi it wouldn't even get a network IP address and the modem never said it was connected. I only need it during the summer, so I got frustrated and put it away after trying all summer. I just got it out again, and was delighted to see this time that it says it's connected, it gets an IP address and sets up a route. But I can't do anything over it. Not even a simple ping.

I use the following to set up the connection:

nmcli c add type gsm ifname cdc-wdm0 con-name ATTBroadband apn broadband

That should be enough for network manager to start enabling the connection as is, but I've also tried manually bringing it up and down with no luck.

On ubuntu, when I see it says it's connected, I can do ping -I wwan0 8.8.8.8 and it works. On raspberry nothing!

I've tried it on three different pis - a 2a+, a zero W, and a regular zero with a redbear wifi adapater. I'm going to try it again shortly on a 3a+ just for shatz and gargles, but don't expect a different result.

At one point, I even tried using an ubuntu rpi image.

Anyone have any clue why I can get this thing to work fine on an ubuntu laptop but not on a pi? I've verified they are using the same drivers (cdc_wdm, qmi_wwan and qcserial with usb_wwan - both ubuntu and raspbian)

SW

  • Raspbian uses neither nmcli nor network manager – Milliways Jun 30 at 3:46
  • USB connected cellular modem – Scott Wood Jun 30 at 11:54
  • but network manager and modem manager are both included in the standard distro repositories and just about any tutorials I have found on setting up a usb based wwan device or a beam specifically use nmcli to set them up. And I have used network manager successfully for other connection types on raspberry pi. But if you know of some way other than using nmcli to enable the device, I don't care how I have to do it as long as it works. Saying "that way isn't used" doesn't help me. – Scott Wood Jul 1 at 17:26
  • and there is no error from the ping - it does nothing until I hit ^C. traceroute just shows * * * * until it gives up – Scott Wood Jul 1 at 17:27
  • I used what I could find online in examples on setting up this device. When I find an example using nmcli, I try the example using nmcli. Since I couldn't find anything in any other method - far away from or up close to whatever 'default' may be, I listed the method that was actually published -- and as mentioned, appears to 'almost' be working. And again, being an ass doesn't help. – Scott Wood Jul 1 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.