0

I am currently setting up a low budget DIY NAS with a raspberry pi 3 B+ and a Samsung 860 QVO 1TB SSD. The pi is connected to my router and I have been able to ssh into it with no problems. I have openmediavault installed on this pi and was able to access the interface with no problems. The problem was that the SSD wasn't displayed in the file systems/disks in the OMV interface. So I did fdisk -l and it turns out that the SSD doesn't show up on the pi itself.

To give some context to the problem, the first time I did the install, I had no troubles at all with the pi and the SSD except when I tried mounting it. As a result, I wiped the micro SD card and did a clean install again. I didn't realize that the ssh file was supposed to disappear so I wiped the SD card again and clean installed it again 2 more times until I realized what I was doing. Now, the ssh connection to my pi is really unreliable and at the moment I cannot ssh into the pi and the openmediavault interface is gone even though I can see the pi and SSD all have power/activity. I waited more than 10 minutes in between each ssh attempt as it worked previously, but as of now, no luck in accessing my pi or openmediavault. I can't power cycle the pi either as I have a headless setup.

I don't think it is a power issue either as the SSD was recognized the 1st time by the pi as well as OMV, but the problem was in mounting.

Please advise me on what to do as I have been stuck for a few days with this problem and don't know what to do. Thank you

  • try regular raspberry pi os - also try booting it with a display attached - you can do a lot more debugging if you can see where it's failing – Jaromanda X Jun 30 at 22:03
  • @JaromandaX I am using Raspberry Pi OS (32-bit) Lite because of my headless setup. Could that be part of the error? I cannot boot it with a display at the moment as I don't have a mini HDMI cable. Should I delete all the files off the micro sd card and do another clean install? The main problem I am facing is that my SSD is not being recognized by the pi and openmediavault. Once I plugged the SSD, the ssh connection to the pi stops working. Please help me. – rain Jun 30 at 22:08
  • oh, sorry, I thought "OMV" was an image - no, lite is all you need for OMV - If attaching an SSD causes power issues, get a better power supply – Jaromanda X Jun 30 at 22:20
  • One thing not sure if you've tried is ... boot the pi without SSD attached and SSH into it ... attach the SSD ... if the connection drops, it's likely a power issue – Jaromanda X Jun 30 at 22:30
  • @JaromandaX i am trying what u suggested now. Thank you for the tip. – rain Jul 1 at 2:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.