0

Raspberry picam is showing blank white images on raspbian buster.The raspberry picam was working with jessie.I tried raspistill -o test.jpg and got a blank white square in test.jpg.

https://drive.google.com/file/d/16jX8nZKGYngVt7yNoyPDUwx03gL1QMKD/view?usp=sharing https://drive.google.com/file/d/16_lQkLHDsCsR1mscDdu5ZF5SeMEVm_Ym/view?usp=sharing

color of the square changes based on programs I use to take the picture for example in picamera(python) it takes black squares, in raspistill it takes white squares.

4
  • Can you post a picture of your wiring? Jul 4, 2020 at 14:00
  • added plz check
    – whitespace
    Jul 4, 2020 at 15:49
  • Did you remember to re-enable the camera in raspi-config (or the GUI equivalent) when you made the Buster install?
    – user115418
    Jul 4, 2020 at 17:27
  • @Andyroo yes, enabled, rebooted and disabled to check if enabling really happened. When enabled it gives the white square as image, when disabled it gives error message saying unable to detect camera.
    – whitespace
    Jul 4, 2020 at 17:46

1 Answer 1

0

This post: Common errors using the Raspberry Pi camera module suggests at least two possible solutions:

  • sudo rpi-update to update Raspberry firmware
  • downgrade the picamera package
3
  • did rpi-update. Both picamera and rpstill are(were) malfunctioning identically so i don't know why updating or downgrading picamera(which is just a python interface) will be help.
    – whitespace
    Jul 5, 2020 at 16:45
  • You did reboot right ? Have you tried raspistill and raspivid ?
    – Kate
    Jul 5, 2020 at 17:30
  • yes both, raspistill and raspivid both successfully record blank white squares.
    – whitespace
    Jul 5, 2020 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.