I run a new installation of Minimal image based on Debian Buster on Raspberry Pi 3B.

sudo apt-get update gone as usuall - 1-2 minutes. However, sudo apt-get upgrade is running already 1:30 or so. And still not finished.

I run another console and see that it's working extremely slow. I saw that login prompt appeared only when a new line in the upgrade window appeared. Further activity in the second shell was related to the activity in the first one. It looks like my RPi virtually stuck with upgrade. But CPU looks almost free of any load:

enter image description here

What can I do to debug the process?

2 Answers 2


It looks like I have had a bad SD card.

After I replaced it with another one - atherything went fine!

  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Jul 10, 2020 at 9:14

This happens because of:

=> Slow mirror server.

=> Slow internet speed.

=> Very slightly because of broken packages.

  • 1
    Slow connection just makes the upgrade take longer. It doesn't stall the entire system. Jul 21, 2020 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.