1

I cannot get any output to use the 3.5 mm headset jack it is stuck on HDMI.

There are lots of questions on here that ask about the headset jack connector not working and have answers on howto switch the output to the jack, so I cover off that answer first as it was my initial try.

if I use the command line option

sudo amixer cset numid=3 1

I get this response from amixer.

amixer: Cannot find the given element from control default

If I try using amixer and the ascii based user interface I can up and down the volume slider using the up/down arrow keys but going left or right arrows makes no difference it still stays on HDMI.

The output of aplay -l is

**** List of PLAYBACK Hardware Devices ****

card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1] Subdevices: 4/4 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones] Subdevices: 4/4 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3

If someone could assist in how I get audio working through the headset jack that would be great. It seems to be a common problem, I am on raspbian buster version.

I suspect that some config file somewhere has been modified and I do not not know how to ensure everything is set to a working condition. So any checks needed to confirm the current setup welcomed.

[EDIT] I have tried the following additional solutions and none of them have resolved the issue.

changed the hdmi_drive parameter in the /boot/config.txt file, this parameter worked as stated, nether value gave sound to analogue jack. Also, checked hdmi_force_edid_audio=1 was not present in config.txt, I tried adding hdmi_ignore_edid_audio and trying amixer once again, still no change. same response on cli from amixer. 'Cannot find the given element from control default'

Thanks Paul

[SOLVED] I ended up solving myself, if you want to hear audio when the RPi is headless through the analogue connector I recommend you do NOT connect the HDMI. Having an interface connected that will not be there during normal run time makes changes that is not always easy to fathom. I simply removed the HDMI off my pi and rebooted then audio was heard through the analogue port, I still have some issues with espeak but by directing the output to aplay it works fine which wikll do form my needs.

Although the answer provided is solid information it DID not resolve my issue.

1

I think manually editing /boot/config.txt might be the corrrect solution.

You should try to comment out hdmi_force_edid_audio=1 in config.txt, add/uncomment hdmi_ignore_edid_audio=1 option, then reboot and try amixer again.

Also you can check option hdmi_drive:

 hdmi_drive=1 Normal DVI mode (No sound)
 hdmi_drive=2 Normal HDMI mode (Sound will be sent if supported and enabled)
| improve this answer | |
-1

[SOLVED] I ended up solving myself, if you want to hear audio when the RPi is headless through the analogue connector I recommend you do NOT connect the HDMI. Having an interface connected that will not be there during normal run time makes changes that is not always easy to fathom. I simply removed the HDMI off my pi and rebooted then audio was heard through the analogue port, I still have some issues with espeak but by directing the output to aplay it works fine which wikll do form my needs.

| improve this answer | |
  • What if you want to have use both? E.g, would it be possible to have both raspotify and Kodi running, and hearing raspotify through the analog audio and Kodi through HDMI? – Fran Villamil Oct 19 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.