0

i have error on updating raspberry pi

pi@TechTSDHacking:~ $ sudo apt-get update

Hit:1 http://deb.playonlinux.com stretch InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Hit:3 https://deb.nodesource.com/node_12.x buster InRelease
Reading package lists... Done
N: Skipping acquire of configured file 'main/binary-armhf/Packages' as repository 'http://deb.playonlinux.com stretch InRelease' doesn't support architecture 'armhf'

plz help see attachad image

please help me

  • You have a bastardised list of sources. Restore to original or re-install. – Milliways Jul 13 at 5:27
  • 3
    whatever you wanted to get from deb.playonlinux.com is not available for raspberry pi period ... only on i386 or amd64 architecture - the real clue is what playonlinux is ... PlayOnLinux is a piece of software which allows you to easily install and use numerous games and apps designed to run with Microsoft® Windows® – Jaromanda X Jul 13 at 5:54
  • @JaromandaX Move your comment to an answer, because you are totally right! – MatsK Jul 13 at 8:06
  • @MatsK - I'm not right, google is : – Jaromanda X Jul 13 at 10:03
3

It seems you have an entry in your /etc/apt/sources.list pointing to a repository at http://deb.playonlinux.com that doesn't support architecture 'armhf'. The Raspberry Pi has this architecture so you cannot use this repository. If so, then comment this line and redo:

rpi ~$ sudo apt update
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.