0

new user here. Finally got around to using my raspberry pi 4B this week and I'm having troubles getting audio from all 3 methods mentioned in the title. I've researched here and there for hours about my problem and to no avail, my problem persists. My goal is to play audio from the pi to my computer monitor that has speakers via HDMI connection.

Steps that I've tried (not in order):

  1. Making sure HDMI cord is plugged into HDMI 0 to the Pi
  2. Unistalled and updated Raspberry OS
  3. Reinstalled PulseAudio and Alsa
  4. Appended "hdmi_drive=2" to the config file
  5. Set audio output to HDMI from the command line and from the configuration menu
  6. Tried playing the .wav file for testing
  7. Tested both monitor speakers and bluetooth speaker with other devices and they do work properly

The problem that I noticed in other help forums is that I'm not seeing a volume button on the top right of my screen. From here people suggest right clicking the icon and selecting either analog or HDMI. The only option I have is selecting the desktop icon "PulseAudio Volume Control" where I can see both outputs and inputs. As of right now, all my inputs and outputs are set to "Dummy Output" and "Monitor of Dummy Output". I'm not sure whether or not having the volume icon at the top right is the cause of my misery since I was able to "force" the output to HDMI.

Last thing. When I connect my JBL speaker to the pi using bluetooth, it will say "Pairing complete. Go to the audio menu to select this device as output". However, when opening the PulseAudio Volume Control program, I do not see my bluetooth speaker. All I see again are the dummy outputs.

Any suggestions would be immensely helpful as I'm trying to finish my first project using my pi.

  • sure you have this line in your config.txt? :: dtparam=audio=on – svin83 Jul 13 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.