1

I run ping -c pi_address and at times get 0% packet loss. But every minute or so, the same command returns 100% packet loss, leading me to believe that the internet connection is unstable on my unit. When I'm connected via eternet, everything works fine. It's only when I'm using wifi I run into unstable connection. My unit is RPi 4 (8 GB) with latest raspberry pi OS lite 32-bit (Kernal 4.19, Version May 2020).

Another observation is, if I use ping pi_address to continuously ping my Pi, my wifi connection seems to be stable (?) and typing command on my Pi through SSH terminal seems responsive. Is this an issue of my wifi card going to sleep after N seconds of inactivity?

Also, as soon as I stop ping pi_address my SSH connection drops (i.e., I can't type anything in the terminal to my Raspberry Pi). It drops almost immediately.

  • Ping is a lousy troubleshooting tool, use a suitable tool like pathping or eq. – MatsK Jul 15 at 19:00
  • 1
    How close are you to the access point, what power supply are you using, is the Pi close to house wireless phones, close to microwave oven, can you change channel on the ap, what security is on the WiFi, 2.4Ghz or 5 any other WiFi devices doing issue, inbuilt WiFi or usb, output of iwconfig wlan0 would help as would sudo iwlist wlan0 scan :). Sorry lots of questions zero answer so far – Andyroo Jul 16 at 0:16
0

This is more speculative than anything... but on my 4 GB rpi4 model and a few others are having this issue as well, the HDMI has some random interference with the Wifi, particularly if you're connected to a 2.4 G band.

Some are saying it gets better if you switch your HDMI cord out, some say the power connected causes it, others you say it clears up when you switch to different resolution settings. In my case, nothing suggested there has really worked except if I remove the monitor for a few minutes, then connect it back up. Wifi works for like 2-3 minutes and then drops back out again so long as the monitor is connected. I'm presently ordering a new cord in hopes that does the trick.

I had hoped to find nothing when I searched for this issue in the 8 GB model, thinking perhaps they may have engineered a solution to it, but perhaps not...

Here's the thread I've been following - hopefully it might offer you some suggestions to help troubleshoot.

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=254640&sid=5d380f680606a5482ee490fe3552d7a7&start=25

| improve this answer | |
  • So you are not answering, just speculating? – MatsK Jul 17 at 17:49
  • For me, the problem just disappeared... I thought it was the power supply, but everything is working fine now. – pairwiseseq Jul 17 at 21:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.