1

I wanna power my servo with the 12V terminal of a Mastercraft Nautilus battery pack (see here)(long story). The servo is a actuonix pq-12 micro linear servo (see here). I'm stepping the voltage down to 5V using a Yeeco DC-DC Buck Converter(see here). I'm controlling the servo with a raspberry pi 4b. Attached is the python code.Raspberry Pi servo code. When I attach VCC and GRD to the PI the servo works perfect. 1 Full extension/retraction. When I attach VCC and GRD to the output terminals of the buck converter...nothing. Note: Control(PWM output) is connected to GPIO17 in both cases. Speaking of the Buck output, they're the right voltage. I've hooked them up to a little LCD circuit. Sure enough, the Buck converter will spit out some current.
I have a couple of guesses so humor me: (a) VCC is in fact the PMW signal. Not the "control" wire connected to GPIO17 (b) The buck converter has a max output current of 5A. Maybe when prompted by control the resistance of the circuit becomes so low that it demands a current>5A. I tried adding a 220ohm resistor to test this theory and no marbles.

Thanks for any help you're willing to provide

EDIT: It works now. My father suggested the problem was to do with the absence of a common ground. I connected the out- and GND pin of the PI, and GND of the servo together. Then I connected out+ of the buck converter to VCC of the Servo and it worked. I am confused why though. The voltage difference between out- and GND(pi) while unconnected was very small, 0.2milli volts. Can anyone explain to me why this alteration was crucial?

Thanks again

2
  • 1
    Ah, common ground is crucial. (1) Your Rpi signal, say 3V, refers to Rpi's own ground reference. When this signal goes to the servo side, which is sort of floating, if there is no common ground, because the servo does not know how the incoming signal is high or low, referring to any ground. (2) The crux of the matter is that the common ground wire actually gives the Rpi voltage signal out to the sever, one way to return to ground. If the Rpi's out signal has no way to return, to form a current loop, then no current = no voltage drop = no signal detected. / to continue, ... – tlfong01 Jul 16 '20 at 1:02
  • 1
    I know it is confusing. If you don't know what I am talking about, let me know, and I will try to give another answer. – tlfong01 Jul 16 '20 at 1:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.