0

I recently bought a brand new Raspberry PI Zero W and flashes rasbian lite onto an SD card and tried to SSH into the pi.

However, after adding in the ssh and the wifi details default files to the boot directory, I kept running into the

channel 0: open confirm rwindow 0 rmax 32768

issue.

I then flashed the "full-fat" rasbian image onto the SD and that worked fine, I SSH'd in first time, so I disabled the desktop and went about with my intentions for this pi.

However yesturday I borked the installation bad and so tried to reflash the SD card, this time though, I can't get past the same channel 0 issue I had before, and I've flashed nearly every OS the raspberry pi imager program allows, and even used the etcher software to flash the card just encase it was the rasbperry pi flashing software at fault.

I have a raspberry pi 4 connected to the same network I've never had any trouble SSH'ing into, and I can run one time commands via SSH on my pi zero perfectly, I've tried updating the pi this way to see if anything changed but it hasn't.

  • 3
    What is the "channel 0: open confirm rwindow 0 rmax 32768" issue? I have no idea if you are saying there is a problem with the Pi or some other device you have attached. – joan Jul 19 at 8:46
  • When i attempt to SSH into the pi from my PC, login seems to go through ok, but then hangs at that step, from a quick google it seems to be a thing that happens to other people, but thus far have never been able to solve. The Raspberry pi 4 works fine, which leads me to believe it might be an issue with the pi zero itself, but it has worked once before and its brand new, not that, that means there couldn't be anything wrong with it, but still. – G33kCentric Jul 19 at 8:52
  • The problem seems related to the router, but no definitive solution is available. Have you tried the -o IPQoS=0 and -o ProxyCommand='nc %h %p' and the reboot of the router? – Ljm Dullaart Jul 19 at 9:34
  • yeah, I've tried that and after a reboot it lets me in once, then never again, and its only the zeros, the Pi 4 never has any trouble. I guess I''ll have to rethink my project. – G33kCentric Jul 19 at 10:14
0

So apprently there are all sorts of possible fixes for this, the one that worked for me is:

ssh pi@192.168.0.xxx 'echo IPQoS 0x00 | sudo tee -a /etc/ssh/sshd_config'
ssh pi@192.168.0.xxx 'sudo shutdown -r now'
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.