0

Allo

I had some power shortages recently that (most likely) caused samba to stop working.

samba --version shows version 4.9.5-debian

I am connecting from Win10. When I try "Add network drive", type the RPI's IP and hit browse, I can see the user's "pi" folder, and the actual samba folder I called "share" --> IP options

I can browse the pi folder, but the share folder says the same thing when trying to access the alrady added and previously working network drive, "Windows cannot access the network folder, check name"

The drive sometimes requests password of user "pi"

Config for the "share" folder is

[share]
Comment=Ostruzina
Path = /media/pi/NAS/Data
Browseable = yes
Writeable = yes
only guest = no
create mask = 0777
directory mask = 0777
Public = yes
Guest ok = yes

All google answers are "how to set up samba", so, I have no idea where even start but here

Thanks in advance :)

  • Have you checked if the pi is at the same IP address? Have you tried checking the SD card is still OK (with sudo touch /forcefsck then reboot - not shutdown then sudo rm /forcefsck). This may stop the Pi running if the card is too bad... – Andyroo Jul 21 at 0:24
  • Have you checked if the pi is at the same IP address? -Yes, I'm still connecting via VNC on the same IP as before Have you tried checking the SD card is still OK -fsck found nothing – Poody Jul 21 at 13:23
  • Possible the security somewhere along /media/pi/NAS/Data is still set to root only. To open this up to Pi try sudo chown -R pi:pi /media - then disconnect the Windows Machine from the Pi (I used to use net use /disconnect but that's Win 7 DOS - no idea on 10) and then reconnect. One minor bit - I normally use /media for CD drives and /mnt for disk drives ('twas the way I was taught no other reason but it helps me remember what is where). – Andyroo Jul 21 at 14:27
0

Solved, the issue was not related to samba, sorry.

Somehow I had a folder called NAS created in /media/pi under the user "root". Maybe when the power went out, the external drive remounted badly. SO when it did remount correctly, the folder NAS was there twice, the correct one renamed to NAS1. Deleting the root one and remounting solved the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.