0

We recently changed the router and set up the devices and everything worked fine.

Except there is my raspberry pi 3 which cannot connect to the new router. It doesn’t show any errors but it simply keeps asking for the password.

Then it tries to connect but after about 30 seconds it asks for the password again.

How can I debug this problem? What is the solution to it?

Wired connection works fine. WiFi does not, but it worked with the previous router.

  • Check your router for any sort of problems. Then try netplan. – Sohan Arafat Jul 21 at 16:53
  • @SohanArafat All the other devices (including another RPi2, running Ubuntu Mate as well) connected successfully. – Ionică Bizău Jul 22 at 6:24
0

I assume this happened because the SSID had emojis in its name, specifically a red heart.

I replaced the heart emoji with an <3 in the name of the router Wifi and then the pi connected fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.