I've just bought a Pi 4 2GB and previously used a Pi 3 B+ (still using it on a dedicated project). Raspberry Pi OS 32 bit systems will not boot. I tried the same SD card on a Pi3 and it boots fine. I used Ubuntu Mate and all other desktop OS systems. They all work just fine, including Raspberry OS 64 bit and Raspberry OS 32 bit. No matter if it is lite, normal, or full desktop images, it just does not boot to the desktop at all. I'm really having headaches over a week. It's essential for me to use the Raspberry Buster 32 bit version to use on my project.

I even tried running a Raspberry Pi 32 bit server and then installing a desktop environment, but that also failed. The main problem with the 32 bit buster desktop image is that when it tries to boot, a rainbow screen comes after that, a blue screen with text saying "Resized root file system." Rebooting in 5 seconds... then gone. Nothing happens when using Putty.

I checked for EEPROM and it's fine, blinking four times. I tried everything, including STICKY solutions. I'm able to install other systems and Raspbian 64-bit but not the one I need. Can someone help me?

For information, other OS systems work perfectly well.

  • so you can install raspberry pi OS 64 and it runs? where do you get that from? Jul 23, 2020 at 20:08
  • @JaromandaX just google it and you will find in raspberrypi.org as beta version
    – Furkan
    Jul 23, 2020 at 20:16
  • I take it you've tried different sd cards - though, that doesn't make sense, since you can boot almost everything else except the 3 versions of 32 raspberry pi OS ... have you tried an older image of any of the 32 bit flavours? Jul 23, 2020 at 21:07
  • @JaromandaX yes first try was a week ago with a 16gb sandisk and now trying with samsung 32gb they both worked perfectly well on pi3b+ and sandisk now runs 3b. No i havent tried but good idea. Should i not update the older one if it works?
    – Furkan
    Jul 23, 2020 at 21:31

2 Answers 2


You can enable the bootloader debug output on the serial console. Maybe you will see what's wrong with the boot process and what the bootloader is missing.

In the EEPROM of the Raspberry Pi 4B you can set a debug flag BOOT_UART=1 as described at Pi4 Bootloader Configuration. Then the bootloader will output low level debug information to the serial debug console on pins GPIO 14 and 15. Look at: What is the correct way to connect serial console on RPi4 Model B?. An example of an output you can find at Serial output in case of no OS.


I experienced the same issue and found a working solution for me.

  • Install the latest Raspberry PI OS from https://www.raspberrypi.org/downloads/raspberry-pi-os/
  • Write it to a SD card with an image writer tool.
  • Put it in a Raspberry PI 3(B) and let it run.
  • Run a full update: apt update && apt -y full-upgrade
  • Shutdown the Raspberry PI 3(B)
  • Put SD card in a Raspberry PI 4 and it should start again

There is a bootloader and kernel update from 23th July. When I have that update on the /boot partition, my Raspberry PI 4 will boot.

I get the feeling that the online images are somehow outdated. So I also expect soon new to see images with the new kernel.

update: I used a 16 or 8 GB SD card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.