1

I know of two methods to do this which I've tried:

  • Use RPi Imager to install Ubuntu on both the SD card and SSD as per this post and this post
  • Install BerryBoot and use that to install and boot Ubuntu from an external drive

I tried the imager method first and got as far as changing the partition lable for the sd card, rebooted, and was hit with an error along the lines of CPU 0 not supported

I then tried the BerryBoot method (which is where I am now), the steps I've done so far are as follows:

  1. Reformatted both the SD card and SSD
  2. Dragged the contents of the BerryBoot zip into the boot partition of the SD card
  3. Downloaded and moved the Ubuntu prepared iso from BerryServer onto a thumb drive
  4. Plugged everything back into the RPi and successfully booted to BerryBoot
  5. And finally, went into the edit menu to install an OS from USB, however BerryBoot completely froze

I've tried reinstalling BerryBoot and rebooting multiple times, however it always freezes until unplugging (I left it for a couple of hours to be sure). It also seems to completely "disconnect" my peripherals as my mouse has RGB and it turns off when BerryBoot freezes.

Edit:
I've found and tried a 3rd method, official raspberry pi os USB boot support.
I've used this guide to get as far as booting from the SSD without the SD card inserted, at which point I was hit with the following errors: https://www.dropbox.com/s/bodn91lp1r9njjg/boot%20errors.jpg?dl=0

Note: I did not use this method to try and boot Ubuntu

Edit 2:
I've been trying a different method using BerryBoot which has worked the best so far. I've managed to install Raspbian 2019.10 using BerryBoot's downloader/installer on first time setup, and after about 10 min on the edit menu screen it works. I'm now attempting to replace the Raspbian install with Ubuntu 20.04
(I think the problem may have been that BerryBoot crashes when loading the edit menu if no OSs are detected)

Edit 3:
Neither Raspbian nor Ubuntu boot from BerryBoot, the OS loads, but gets tonnes of errors and doesn't finish booting.

0

this thread may be helpful getting you up and running. if you read the entire thread it is apparent that at this point in time your mileage may vary.

RPI4 Direct USB Boot Ubuntu 20.04

I was able to follow the instructions and get everything up and running, and actually seemingly pretty stable. However, once i ran sudo apt update && sudo apt upgrade Ubuntu had issued an update to their firmware which replaced my *.elf and *.dat files, which in turn required me to re-copy them over to the USB drive from my laptop where I had the working ones backed up. That's when things seemed to go wonky on me and i began having a number of device-level problems.

I have since moved to the Raspbian 64-bit Beta and haven't had any problems so far. I plan to stay there until Ubuntu gets its USB boot issues sorted out, which seems like it may take a few months from now (25 July 2020).

Either one you choose, you will need to be sure to set your Pi to the "stable" channel for firmware, and you have the 06_15_2020 firmware installed. The instructions for both are in this thread.

Good luck!

| improve this answer | |
  • I've already tried the official boot method (which includes setting channel to stable), and am, in fact, posting an answer as I was able to get it working. – 100pxsquared Jul 26 at 12:33
  • Also, based on your answer, you didn't fully read my question as you repeated information. Please make sure you read a question fully before trying to answer it. – 100pxsquared Jul 26 at 12:44
  • i did read the question fully, the snark is unnecessary. based on the information in your question, taking the problem back to basics without BerryBoot seemed the best approach. turns out no amount of free, earnest help can account for the purchase of suboptimal hardware. I would suggest going with the newer Realtek 9210 chipset at this point, runs cooler and has fewer quirks – mindpivot Jul 27 at 14:39
  • I really didn't mean anything bad by my comment. I saw you were a new user and that you had repeated steps I had already said I'd tried, so I pointed it out. – 100pxsquared Jul 27 at 18:33
0

I was finally able to get Raspbian to boot from USB using official boot support.
It was either luck, or because of the drive enclosure chipset.

I found this page which details that certain chipsets don't work, and only listed one good one.
However further down the page there's a section on fixing (some) adapter problems using quirks, which involves editing /boot/cmdline.txt and adding an entry at the start like this usb-storage.quirks=XXXX:XXXX:u, where the X's are replaced with the ID of your adapter (which you can find using sudo lsusb, see the linked page for details)

I'm not sure whether this was the fix or not but it did work after doing this.
(FYI my adapter is a JMicron Generic SCSI Disk Device)

| improve this answer | |
0

I managed to successfully install Ubuntu on two separate ssd / usb drives and boot my Pi 4 from it. I find this guide to be quite good.

https://eugenegrechko.com/blog/USB-Boot-Ubuntu-Server-20.04-on-Raspberry-Pi-4

Make sure to follow the instructions carefully, especially the part where you update your Pi's EEPROM since it can break your chip.

Feel free to ask if you have any questions.

Regards

| improve this answer | |
New contributor
Thomas S is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.