0

My new password is being rejected at first use. Following previous threads I used the init=/bin/sh to the cmdline file. On bootup I receive message "job control turned off." The ending of the cmdline file is different to all examples shown inas mucha s it does not end at "deadline rootwait" but ends "quiet splash plymouth.ignore-serial-consoles"

Do I place the "init..." immediately after "rootwait" as placing it at the end of the present line (as shown below) results in "job control turned off"?

"console=serial0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles init=/bin/sh"

1
  • You are obviously using NOOBS - all the tutorials assume normal Raspbian.
    – Milliways
    Jul 24, 2020 at 23:15

1 Answer 1

3

Do I place the "init..." immediately after "rootwait" as placing it at the end of the present line (as shown below) results in "job control turned off"?

As far as I'm aware the order of the parameters doesn't matter, although there could be exceptions to that. What is important is that the file be all one line.

The "job control turned off" isn't because of that, it's because something is wrong with the system -- eg., the kernel can't properly access the root filesystem to load some needed module, although it clearly can in some sense since this the message is actually from /bin/sh, the shell. You can read up on job control if you like; not having it is not a huge problem if all you have to do is set a password, but what it is symptomatic of may be a huge problem: If there is not proper read-write access to the root filesystem, setting a new password will fail one way or another.

At the prompt, try: mount | grep mmcblk0p7. You should get this:

/dev/mmcblk0p7 on / type ext4 (rw,noatime)

The important part is the rw (read-write) in parentheses. If you don't have that, the problem may be SD card corruption that could not be fixed by fsck (which is enabled in your cmdline.txt).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.