0

I normally boot my RPI 3B+ from a USB SSD (RaspiOS Buster Lite, may 2020 version), but when I plug an external wifi dongle (Mediatek Ralink RT5370N) it just does not boot and the red LED stays on indefinitely while the green LED stays off. The wifi dongle works normally if plugged after boot.

The RPI is powered by a 4A adaptor.

So far I have tried to: i) change the boot settings from cmdline.txt (explicitly writing the part-uuid of the boot drive); ii) upgrade the rpi and rpi firmware.

4
  • Have you tried swapping over the USB ports the dongle and SSD are connected to?
    – Pokebab
    Jul 26 '20 at 10:19
  • @Pokebab I have tried but it was uneffective Jul 26 '20 at 14:59
  • 1
    The power is an obvious thought. The USB ports are limited to the amount of current they can provide and the power supply is irrelevant as on board chips limit the supply. Try a powered USB hub. Note use a power supply NOT an adapter.
    – user115418
    Jul 26 '20 at 17:07
  • @Andyroo actually this is the solution! I just added the option max_usb_current=1 to the config.txt file and everything's working right even without a powered usb. Let me know if you'd like to add the solution yourself or if you prefer me to do it. Jul 26 '20 at 17:11
0

The issue was caused by excessive current withdrawal on the USB port of the RPi. I solved the issue by adding the option max_usb_current=1 in config.txt.

By doing this the maximum current provided by the USB ports on the RPi is increased from 0.6A to 1.0A. Bear in mind that you must have a powerful enough power supply.

An alternative solution would be to have an externally powered USB hub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.