0

What is the issue here? LCD has backpack. Connected following schematic to Pi:

enter image description here

I2C is not detecting adress of PCF8574:

enter image description here

Things I have already tried:

  • Reinstalling I2Ctools, ensuring I2C is turned on etc
  • Changing I2C clock speed (Max for PCF8574 is 100kHz)
  • Supplying VCC with 3.3V instead of 5V
  • Checking all connections are correct
  • Checking I2C functions correctly with another I2C chip, works perfectly fine
  • Switching SCL and SDA connections

LCD does light on.

Photos of wiring: enter image description here enter image description here enter image description here Is there something I'm missing here? Or should I conclude that the backpack is faulty? Thanks in advance

  • You have not made the proper connections. We need clear photos of the connections you have made. – joan Jul 26 at 10:50
  • @joan I have added the photos as you requested. The connections look fine to me. – Pokebab Jul 26 at 11:20
  • 1
    You need to show the Raspberry Pi end of the ribbon cable. The common failure is fitting the ribbon without getting PIN#1 on the cable connected to PIN#1 on your RPi. Check the voltage on the two 5V and two 3V3 pins on your breadboard. – Dougie Jul 27 at 16:32
1

An I2C Bus needs pullup resistors on the clock and on the data wire. If neither the raspi nor the Backpack attaches these pullups, the bus can not work correctly.

Here is a good intro: https://learn.sparkfun.com/tutorials/i2c/i2c-at-the-hardware-level .

I don't see any pullups in your schematics.

Attention: The raspi does NOT tolerate 5V, so don't use 5V for the pullups.

If the Backpack does not work with 3.3V (But there is a good chance it does work with 3.3V.) you need a level shifter.

| improve this answer | |
  • Take a look at the photos I've added where you can see the backpack and connections. I think there might be pull ups on the backpack but I can't be sure, I'm following a Freenove tutorial that came with the kit that supplied jumpers, lcd board with backpack soldered on etc. – Pokebab Jul 26 at 11:25
  • I found a video on youtube, where the Module was installed on a raspi. They do not use pullups. So I think it should work without. youtube.com/watch?v=3XLjVChVgec . On the pictures I saw some VCC and GND connection from the raspi to another target. Do you use the raspi to power another device too. Perhaps LCD and this board are too much for the little guy. – Peter Paul Kiefer Jul 26 at 11:51
  • I power a small Raspberry Pi fan with it. Just to check, I disconnected the fan and tried again, still no result. – Pokebab Jul 26 at 11:58
  • I don't see any further problems. Perhaps the module is deffect or you did some faulty configuration on raspi. The following video is from the raspi guy who wrote a autoconfiurator for the usage of these display on a pi. Perhaps it helps. youtube.com/watch?v=fR5XhHYzUK0 – Peter Paul Kiefer Jul 26 at 12:08
  • I tried following this video and unfortunately it's still not detecting the address in i2cdetect. I think there may be a problem with the backpack soldering. – Pokebab Jul 26 at 12:27
2

I'm now certain there is an issue with the backpack or board. After further inspection, I noticed that the plastic insulation at the base of the ground pin on the backpack and on the LCD board appear to be damaged. It looks like it was shorted. It could have been me, but I doubt it as I was very careful in wiring, especially as I know the damage that can be caused by shorting 5v and ground pins on the Pi, my Pi seems fine. I believe that the board was shorted prior to my using it, which damaged the chip. I hope.

enter image description here

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.