I'm having a very weird problem where if I overclock the SD card reader on my Pi 3B+ using dtoverlay=sdhost,overclock_50=100 the wireless stops working. Raspi-config says 'No wireless interface found'. How do I fix this?

System details:

  • Raspberry Pi 3 Model B+
  • Latest version of Raspberry Pi OS Lite
  • 4
    Are you sure that is weird? Generally overclocking is at your own risk. There is also a warning saying this will kill the wifi.
    – joan
    Jul 27, 2020 at 21:45
  • I haven't seen that warning before. What was weird was the 2 things which seem very unrelated to each other. The reason I'm doing this is because I'm using the Pi as a mini-NAS (I know, an SD card isn't great for it) and my R/W speeds are very bad (5mb/s)
    – dominic03
    Jul 28, 2020 at 1:44

3 Answers 3


You asked how to fix the overclocking problem. I would say the solution is: don't overclock the Raspberry Pi because you are also get a warning that it may kill your WiFi.


Rather than worrying about an SD card, I moved what I wanted to serve to my network to USB flash drives. This way the system doesn't become unresponsive and/or have slow write speeds when many files are being copied to it.


The speed issue is your SD card. A good card will manage 20+ MB/s at stock settings. Your bottleneck is not SDIO speed, it is the card.

WiFi is on the 2nd SDIO interface. So, you also overclocked WiFi interface when you overclocked the SD.

Maybe there is a way to set different speeds on the two interfaces, maybe there isn't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.