0

I have a 16GB micro SD card, on which raspbian strecth 2018-03-13 is installed (via win32diskimager, earlier formatted via SD card formatter). It works perfectly for my RPi zero model, but doesn't work for my RPi3A+ model. Though my RPI3A+ works perfectly for 2020-05-27 version of raspbian, but because that version doesn't support linux tool "perf", I am willing to use the older vesion which supports "perf".

How am I supposed to access the older version of raspbian stretch on my RPi3A+ model? Or is there any way where the perf tool can be accessed / installed for the latest version (2020-05-27)?

0

The Pi3A was released on 15 Nov 2018.

Any OS older than this won't work, although you COULD try updating kernel and firmware from a later release.

NOTE DO NOT use rpi-update (at least without selecting a Stretch compatible release - which is not quite straightforward).

Running sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will install the latest supported kernel/bootcode, but this assumes you have a Pi that can boot - should be OK if run on the Pi Zero.

| improve this answer | |
  • I inserted the SD card into RPi zero and ran the above 2 mentioned commands: sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel . After that, I inserted back the card into my RPi 3A+, this time the green light did blink thankfully, but still I couldn't connect it to my laptop. What could be the possiblereason for that? – Sukhmani Kaur Thethi Jul 31 at 7:35
  • @SukhmaniKaurThethi DO NOT ask questions in Comments, update your question or ask a new Question. Unless you provide some details no one can say. – Milliways Jul 31 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.