2

I have a Raspberry Pi 3 Model B V1.2. I downloaded the latest, 2020-05-27-raspios-buster-full-armhf.img, installed it from Linux via dd. It runs. It goes through many reboots, updating and installing software each time. I updated software a few times via "apt-get update; apt-get upgrade" successfully, rebooting as necessary.

In the middle of yet another update, the screen went black, and the RPi halted. Attempts to reboot fail, with the green LED flashing 7 times, apparently indicating that kernel.img can't be found.

I mounted the microSD on Linux, and can see the files in /boot and /rootfs. I ran a "find" search on both partitions, but I cannot see any file called kernel.img

I've already installed the OS twice, each time ending with one of the updates crashing, and then not being able to boot. I tried another microSD from another pi, and my RPi boots just fine from that microSD, so it's not the RPi.

Any ideas on how to fix this?

I bought a new card, verified that it was really from SanDisk. (Turns out the original was too, but appeared to become unusable in the middle of upgrading raspbian.) Today, I started all over...no apt or apt-get. When the RPi updated software on its own, it suddenly rebooted, and then couldn't get up again. The green LED flashed 7 times. I looked at the SD card on Linux. Both partitions are there, but there were no kernel files in /boot! As an experiment, I saved the 2 partitions on my Linux box. After the RPi failure, I copied the kernel*.img files to the card. Alas, it did not work. Undoubtedly, it needed other files too.

BTW, apt-get autoremove just gets rid of old dependencies, that are no longer needed. The differences between apt and apt-get are superficial, apt being created to make apt-get easier to use. Thanks for the pointer. Changing to apt will be a bit less typing. (I've been using Unix & Linux since the 1980's.)


This is around the 7th time I've cycled through the installation process. When the automatic, I have nothing to do with, updates happen, the RPi reboots and hangs because it can't find the kernel image! WTF?

Is there some way to mount the microSD on a Linux box and stick the right files where they're supposed to go? Automatic is NOT WORKING!

3
  • 1
    Try another SD Card
    – Milliways
    Jul 28, 2020 at 22:52
  • Once you have a new card I would also add for you to stop using apt-get and update. It's now suggested to use apt (better for interactive use) and full-upgrade raspberrypi.org/documentation/raspbian/updating.md one thing that is currently odd is the need to run a sudo apt autoremove to take out the eeprom files if you are not on a Pi 4 - it's not mentioned in the notes linked and not an issue if left around but it's just been updated in the full-upgrade (such a waste of electrons) :-)
    – user115418
    Jul 29, 2020 at 2:44
  • 1
    the fact that It goes through many reboots and you *updated software a few times suggests something very wrong with the SD card - because after initial image install, you'd apt update / upgrade once to get the latest of everything - it's not like Microsoft windows :p Jul 30, 2020 at 6:10

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.