0

I just got a new RaspberryPi 3B+ and have added an empty SSH file with no extension a wpa_supplicant.conf file that contains the following to my microSD card:

country=US update_config=1ctrl_interface=/var/run/wpa_supplicant
network={
ssid="MyNetworkName"
psk="MyPasswordName"
}

When I insert the SD card into the Pi and plug it into a power supply that outputs 2-3 Amps the red light remains steady after the green one stops flashing and when I try this command in the terminal: 

ping raspberrypi.localping: cannot resolve raspberrypi.local: Unknown host

Is the response^ 

Yet when I try this command: 

ping raspberrypi
PING raspberrypi (00.000.000.0): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1

Is the output with a continued series of "Request timeout..." messages and my actual IP address. Does anyone know why the Pi is not responding to the first command with the '.local' suffix or does it even matter?

Also, I removed the SD card after trying this and checked that the wpa_supplicant.conf file is still there and that the wifi details and punctuation, country code are correct.The SSH file is also still there and I am aware it should be removed when the Pi boots so I don't think it is actually booting.

Thanks for any advice, I am beginner so sorry if this is a dumb question. Thank you.

  • Ian
3
  • If the file is still there something has gone wrong. Your file is incorrectly formatted. – Milliways Jul 28 '20 at 22:50
  • To expand on the other comment here, if you prepared/edited the files on a Windows machine, you may have confused the RPi. Windows uses "line control" characters that other systems can't process correctly. – Seamus Jul 29 '20 at 19:23
  • How do you add an empty ssh file with no extension and a wpa_supplicant.conf file to the SD Card? I guess you use a card reader on another computer. What operating system is running on that computer? – Ingo Aug 2 '20 at 18:35
1

It probably booted ... but not with WiFi and ssh enabled.

WiFi

The formatting on your post makes it look like you may have missed some info in your /boot/wpa_supplicant.conf

It should resemble this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=<Insert 2 letter ISO 3166-1 country code here>

network={
 ssid="<Name of your wireless LAN>"
 psk="<Password for your wireless LAN>"
}

Refer to: https://www.raspberrypi.org/documentation/configuration/wireless/headless.md And also: https://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

ssh

As for ssh, in your post, you typed SSH in all caps. I'm only ever used to seeing this is lower case (and have never tested it with upper-case). My guess is that it didn't recognize the name (Unix/Linux filesystems are case-sensitive.)

See 3. Enable SSH on a headless Raspberry Pi (add file to SD card on another machine) on this page: https://www.raspberrypi.org/documentation/remote-access/ssh/README.md

The reason I suspect neither file was accepted is because the Pi will normally remove those files from the /boot folder once those configuration changes are made. The fact that they are still there suggests to me that the OS didn't like them.

ping

Those issues aside, once you successfully get your Pi to join your WiFi network, you can refer to it by the ".local" domain if the computer you are using supports mDNS. Most Macs or Linux machines support this (as does the Raspberry Pi). Windows does have some support for this but it might not be enabled.

This page talks about techniques to try to find the IP address: https://www.raspberrypi.org/documentation/remote-access/ip-address.md

5
  • Hi Tim, Thank you for this advice. I made the recommended changes to the ssh and wpa_supplicant.conf files and am getting the same responses from the pings that I included in the first post. After plugging the SD card back into the computer and this time the ‘ssh’ file had been removed. The IP addresses of devices on my network are different from the one the Pi is returning in the command line. When would you recommend using a keyboard and screen to diagnose the issue? I can buy them if required. Thanks again for any advice. - Ian – Ian Evans Jul 29 '20 at 1:15
  • If you are on a Windows PC then there is a good chance it does not have Bonjour loaded. This is a package designed to handle the '.local' networking and can be installed with iTunes or direct from Apple (yup - no joke) Only newer code on PCs handle this addressing correctly. It can be downloaded from support.apple.com/kb/DL999?locale=en_GB (it was coded for printers hence the odd name) en.wikipedia.org/wiki/Bonjour_(software) Has a basic intro. – user115418 Jul 29 '20 at 10:46
  • It appears that Windows 10 does natively have mDNS (no need to install 3rd party software) but it may not be enabled. This article on SuperUser (Stack Exchange) mentions a registry entry that enables the service: superuser.com/questions/1330027/… (I have not tested this.) – Tim Campbell Jul 29 '20 at 14:40
  • Thanks everyone for these suggestions. I finally got it working by plugging the Pi into the TV via HDMI and setting up the network settings and hostname with a keyboard. Thankfully that worked and I can now access it headless. – Ian Evans Aug 4 '20 at 1:37
  • @IanEvans Please make your comment to an answer and accept it after two days. Only accepting an answer will finish the question and it will not pop up again and again for years. – Ingo Aug 7 '20 at 18:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.