I'm trying to install omxplayer on raspberry pi 4 (Debian Buster x64) but I'm having so much trouble and can't install it. First of all I tried:

apt update
apt install omxplayer

And had the following message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package omxplayer is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'omxplayer' has no installation candidate

Next I tried to build from the source (https://github.com/popcornmix/omxplayer) So I tried the following command to do it:


And it gave the the following error:

Modifying for native build on Debian
Checking dpkg database for missing packages
You are missing required packages.
Run sudo apt-get update && sudo apt-get install  git-core libasound2-dev libva1 libidn11-dev libboost-dev libssl1.0-dev libssh-dev libsmbclient-dev

So I run the command that it told me too, but now I have another error:

Package libssl1.0-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package libva1
E: Package 'libssl1.0-dev' has no installation candidate

Now I don't know what also I can do to install this program, it is realy usefull and I realy need it for an project. Does anyone knows what can I do? Thank you.

  • Can you install any packages at all? Looks like a configuration problem. Did you change anything in /etc ? Commented Jul 29, 2020 at 23:04
  • @DmitryGrigoryev No I didn't changed anything on /etc and I can install other packages (installed guake right now)
    – Rafael
    Commented Jul 29, 2020 at 23:10

4 Answers 4


Well I now installed the 32bit image on my raspberry pi 4 (Raspberry Pi Imager from official website) and the program is even pre-isntalled. I read in github that the omxplayer is not yet shipped to 64bit arquitecture that was the image I was using (Debian Buster x64)


Make sure to run apt update with sudo: sudo apt update, and also to install all of your packages with sudo. If you haven't done it recently, also run sudo apt upgrade.

  • ye I run eveyhing with sude and also did apt full-upgrade and still is not working
    – Rafael
    Commented Jul 29, 2020 at 23:38
  • It seems to me like the apt repo containing omxplayer is not present on your OS. Does downloading from here work? You could also try installing it with snap Commented Jul 30, 2020 at 6:03

From the omxplayer repository:

Note: omxplayer is being deprecated and resources are directed at improving vlc. This is due to: omxplayer uses openvg for OSD and subtitles which isn't supported on Pi4. omxplayer uses openmax which has been deprecated for a long time and isn't supported with 64-bit kernels. omxplayer does not support software decode omxplayer does not support advanced subtitles omxplayer does not support playback from ISO files. omxplayer does not integrate with the X desktop.



I had this issue until I reimaged my SD card with the "Raspberry Pi OS (Legacy)", second from the bottom under the "Raspberry Pi OS (other)" category in the Pi Imager. After baking the Legacy OS to my card, I put it into my Pi 3 and followed the Adafruit guide at https://learn.adafruit.com/raspberry-pi-video-looper/installation and had no issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.